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ELŐSZÓ 

A technikai fejlődés, a gazdaságos tömegtermelés, illetve az elvárt, magas 
szintű minőség iránti igény lényegesen megreformálta a mérési adatok 
gyűjtésével, tárolásával és megjelenítésével szembeni követelményeket. 

A méréstechnikát tekinthetjük korunk egyik legnélkülönözhetetlenebb 
tudományágának. Az ipar számos területén napi feladatként jelentkeznek a 
különféle mérési eljárások kidolgozása és végrehajtása. A mérési feladatok 
bonyolultsága azonban egyre nehezebbé tette a mérési eredmények 
kiértékelését. Az általános célú mérőeszközökön és a speciális feladatokat 
ellátó célműszereken és -berendezéseken keresztül a fejlődés irányvonala az 
automatikus mérőrendszerek felé mutat, mely az imént említett nehézség 
leküzdésének egyik fő lehetősége. A méréstechnika egyrészt a legkorszerűbb 
technológiát használja, másrészt a már alkalmazott és jól bevált mérési 
módszerekre és technikákra támaszkodik. 

A számítógépek megjelenésével és rohamos fejlődésével megvalósulhatott a 
mérési adatok kor igényeinek megfelelő feldolgozása, valamint a teljes 
mérési folyamat automatizálhatósága. A mérési adatok gyűjtése és tárolása 
automatikusan történhet, adott szoftver segítségével pedig lehetséges a 
mérések grafikus és numerikus kiértékelése és nyomtatása. A felhasználók 
többsége szereti a mért értékeket a mérés pillanatában azonnal látni, azaz a 
valósidejű kijelzést. A mai szoftverek tartalmaznak real-time adatkijelzést is. 

A mérési adatok gyűjtésének és tárolásának további céljaiként megemlíthető 
a különböző rendszerek működésének ellenőrzése, a hosszútávon rögzített 
adatok alapján a tervezett és a megvalósított rendszerek összehasonlítása, a 
rendszerekben rejlő lehetőségek felismerése és a megvalósításukhoz 
szükséges adatok kinyerése, valamint a szükséges módosítások elvégzése az 
optimális hatásfok érdekében. 

Összegezve elmondhatjuk, hogy noha életünk fontos és mindennapi 
eszközeinek tekinthető a papír és a ceruza, manapság a mérési adatok 
gyűjtésekor, tárolásakor és regisztrálásakor jelentősen háttérbe szorulnak. 
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E könyv korszerű adatgyűjtési és tárolási lehetőségeket mutat be. 

A fejezetek felépítése a következő: 

Az 1. fejezet az SI alap- és származtatott egységeit és a prefixumokat 
ismerteti, valamint egy rövid áttekintést ad a szenzorokról és az adatgyűjtés 
lehetőségeiről. 

A 2. fejezet egy LabVIEW környezetben végrehajtható hőmérséklet 
konverziót mutat be. 

A 3. fejezetben mérési adatok gyűjtése, tárolása és megjelenítése szerepel 
LabVIEW környezetben célhardver alkalmazása nékül. 

A 4. fejezet, illetve az 5. fejezet az NI USB-9211 típusú adatgyűjtő 
ismertetését, valamint a vele történő adatgyűjtés lehetőségeit foglalja össze. 

A 6. fejezet az NI USB-6009 multifunkciós I/O eszköz jellemzőit, valamint az 
adatgyűjtés lehetőségeit mutatja be néhány rövidebb példán keresztül. 
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1. BEVEZETÉS A MÉRÉSI ADATOK 
GYŰJTÉSÉBE 
A mérés olyan tevékenység, mellyel azt határozzuk meg, hogy a mérendő 
mennyiség hányszorosa vagy hányad része a számára alapul választott 
egységnyi mennyiségnek. 

A méréstechnikában egyre nagyobb szerep jut a mérési adatok gyűjtésének, 
tárolásának és megjelenítésének. 

A méréstechnika azon eszközöknek és módszereknek az összessége, 
melyekkel valamilyen fizikai jellemző (mérendő mennyiség) számtani értéke 
meghatározható. Végeredményként egy szám és egy mértékegység szorzatát 
kapjuk (pl. 30 °C). A mérési módszereket sokféleképpen osztályozhatjuk. A 
leggyakoribb csoportosítás a következő: 
• közvetlen vagy közvetett, illetve 
• analóg vagy digitális. 

Ez a fejezet rövid áttekintést nyújt az SI alap- és származtatott egységeiről, a 
prefixumokról, valamint a jelátalakítás és adatgyűjtés alapelveiről. 

1.1. Az SI alap- és származtatott egységei, prefixumok 

A fizikai mennyiségek egységes mértékegységrendszereként a Nemzetközi 
mértékegységrendszer (SI, International System of Units) szolgál. Ez alapján 
megkülönböztetünk alap- és származtatott egységeket. A hét alapegységet 
az 1. táblázat mutatja be. 

1. táblázat Az SI alapegységei 

Mennyiség Egység 
Név Jel Név Jel 

hosszúság l méter m 
tömeg m kilogramm kg 
idő t szekundum s 
elektromos áramerősség I amper A 
termodinamikai hőmérséklet T kelvin K 
anyagmennyiség n mól mol 
fényerősség Iv kandela cd 
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A származtatott egységek az alapegységekből, illetve más származtatott 
egységekből vezethetők le. A származtatott egységek - a teljesség igénye 
nélküli - felsorolását adja a 2., 3. és 4. táblázat. 

2. táblázat Példák az SI származtatott egységeire 

Mennyiség Egység 
Név Név Jel 

terület négyzetméter m2 

térfogat köbméter m3 

sebesség méter per szekundum m·s-1 

gyorsulás méter per szekundum négyzet m·s-2 
hullámszám reciprok méter m-1 
sűrűség kilogramm per köbméter kg·m-3 
fajlagos térfogat köbméter per kilogramm m3·kg-1 

áramsűrűség amper per négyzetméter A·m-2 
mágneses térerősség amper per méter A·m-1 

koncentráció mol per köbméter mol·m-3 
fénysűrűség kandela per négyzetméter cd·m-2 

3. táblázat Példák olyan SI származtatott egységekre, melyek külön névvel 
és jellel rendelkeznek 

Mennyiség Egység 

Név Név Jel Kifejezés SI 
alapegységekkel 

síkszög radián rad m·m-1 = 1 
térszög szteradián sr m2·m-2 = 1 
frekvencia hertz Hz s-1 
erő newton N m·kg·s-2 
nyomás pascal Pa N/m2, m-1·kg·s-2 
energia, munka, hőmennyiség joule J N·m, m2·kg·s-2 
teljesítmény watt W J/s, m2·kg·s-3 
elektromos töltés coulomb C s·A 
elektromos feszültség volt V W/A, m2·kg·s-3·A-1 
kapacitás farad F C/V, m-2·kg-1·s4·A2 
elektromos ellenállás ohm Ω V/A, m2·kg·s-3·A-2 
elektromos vezetőképesség siemens S A/V, m-2·kg-1·s3·A2 
mágneses fluxus weber Wb V·s, m2·kg·s-2·A-1 
mágneses indukció tesla T Wb/m2, kg·s-2·A-1 
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4. táblázat Példák olyan SI származtatott egységekre, melyek neve és jele 
külön névvel és jellel rendelkező SI származtatott egységet tartalmaznak 

Mennyiség Egység 

Név Név Jel Kifejezés SI 
alapegységekkel 

dinamikai viszkozitás 
pascal 
szekundum 

Pa·s m-1·kg·s-1 

nyomaték newtonméter N·m m2·kg·s-2 

felületi feszültség 
newton per 
méter 

N/m kg·s-2 

szögsebesség 
radián per 
szekundum 

rad/s m·m-1·s-1 = s-1 

szöggyorsulás 
radián per 
szekundum 
négyzet 

rad/s2 m·m-1·s-2 = s-2 

hőáramsűrűség 
watt per 
négyzetméter 

W/m2 kg·s-3 

hőkapacitás, entrópia 
joule per 
kelvin 

J/K m2·kg·s-2·K-1 

fajlagos hőkapacitás, 
fajlagos entrópia 

joule per 
kilogramm 
kelvin 

J/(kg·K) m2·s-2·K-1 

fajlagos belső energia 
joule per 
kilogramm 

J/kg m2·s-2 

hővezetés 
watt per 
méter kelvin 

W/(m·K) m·kg·s-3·K-1 

energiasűrűség 
joule per 
köbméter 

J/m3 m-1·kg·s-2 

elektromos térerősség volt per méter V/m m·kg·s-3·A-1 

térbeli töltéssűrűség 
coulomb per 
köbméter 

C/m3 m-3·s·A 

felületi töltéssűrűség 
coulomb per 
négyzetméter 

C/m2 m-2·s·A 

dielektromos állandó 
farad per 
méter 

F/m m-3·kg-1·s4·A-2 
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Az eredeti egység többszörösének, illetve tört részének kifejezésére 
használjuk a prefixumokat (5. táblázat). 

5. táblázat Prefixumok 

Szorzó Név Jel 
10-24 yokto y 
10-21 zepto z 
10-18 atto a 
10-15 femto f 
10-12 piko p 
10-9 nano n 
10-6 mikro µ 
10-3 milli m 
10-2 centi c 
10-1 deci d 
101 deka da 
102 hekto h 
103 kilo k 
106 mega M 
109 giga G 
1012 tera T 
1015 peta P 
1018 exa E 
1021 zetta Z 
1024 yotta Y 

Példák: 
• 3 pF = 3∙10-12 F = 0,000000000003 F, 
• 3 mA = 3∙10-3 A = 0,003 A, 
• 3 GW = 3∙109 W = 3 000 000 000 W, 
• P = U∙I = 3 mV∙3 mA= 3∙10-3 V∙3∙10-3 A = 9∙10-6 V∙A = 9∙10-6 W = 9 µW 

vagy 0,009 mW. 

 
A prefixumokat tilos többszörösen használni (pl. 3 µkg): 
• 3 µkg = 3 mg = 0,003 g. 
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1.2. Szenzorok 

A fizikai, így a mérendő mennyiségek száma végtelen. A szenzor vagy 
érzékelő (1. ábra) olyan átalakító, mely a fizikai mennyiséget feldolgozható 
formába (villamos jellé) konvertálja. 

 

1. ábra Szenzor 

A szenzorok karakterisztikáit két csoportba sorolhatjuk: statikus és 
dinamikus. A statikus leírja a kimenet és a bemenet közötti kapcsolatot, ha 
a bemenet nem változik. Néhány statikus jellemző: 
• méréstartomány, 
• pontosság, 
• felbontás, 
• érzékenység, 
• linearitás, 
• hiszterézis és 
• kúszás. 

A dinamikus a rendszer bemenete és kimenete közötti kapcsolatot adja meg, 
amikor a mérendő mennyiség gyorsan megváltozik. Három típusa: 
• Nulladrendű (pl. egy potenciométer, 6. ábra), ahol a bemenet és a 

kimenet lineáris kapcsolatban áll: 

x(t)ya 0 =⋅ . (1) 

• Elsőrendű (pl. egy higanytöltésű hőmérő folyadékba merítéskor), ahol a 
bemenet és a kimenet közötti kapcsolat egy elsőrendű differenciál-
egyenlettel adható meg: 

x(t)ya
dt
dy

a 01 =⋅+⋅ . (2) 
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• Másodrendű (pl. egy tömeg-rugó-csillapító rendszer vagy egy tokkal 
ellátott hőmérő), ahol a bemenet és a kimenet kapcsolatát egy 
másodrendű differenciál-egyenlet írja le: 

x(t)ya
dt
dy

a
dt

yd
a 012

2

2 =⋅+⋅+⋅ . (3) 

A 2. ábrán egy tömeg-rugó-csillapító rendszer MATLAB Simulink modelljét 
láthatjuk. 

 
2. ábra Tömeg-rugó-csillapító rendszer MATLAB Simulink modellje 

A válaszfüggvényeket a 3. ábra szemlélteti. 

  

 

3. ábra Választípusok: túlcsillapított, kritikus csillapítás, alulcsillapított 

Túlcsillapított Kritikus csillapítás 

Alulcsillapított 
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A hőmérsékletet az egyik legfontosabb mérendő mennyiségnek tekinthetjük, 
ami számos további mennyiség (pl. elektromos ellenállás, elektromos 
feszültség, nyomás, térfogat, hosszúság) alakulására is kihatással van. 

A 3. és 4. fejezetben K típusú hőelemet (termoelemet), mint érzékelőt 
használunk a hőmérsékleti adatok gyűjtéséhez. A termoelem két különböző 
anyagi minőségű villamos vezetőből áll, melyeket egy pontban egyesítenek 
(pl. összeforrasztanak). Ha e pont hőmérséklete melegítés vagy hűtés 
hatására eltér a szabad végek hőmérsékletétől, akkor olyan elektromos 
feszültség mérhető a szabad végek között, mely a hőmérsékletkülönbséggel 
arányos. 

A hőelemeknek számos típusa létezik. A négy leggyakrabban használt típus: J, K, 
T és E. A K típusú hőelem egyik szára 90 % nikkel és 10 % króm, míg a másik 
szára 95 % nikkel, 2 % mangán, 2 % alumínium és 1 % szilícium 
összetevőből áll. Különböző felhasználási célú hőelemeket szemléltet a 4. 
ábra. 

  

 

4. ábra Különböző kivitelű termoelemek 

A hőelemek mellett széles körben kerülnek felhasználásra az ellenállás-
hőmérők is, melyek működési elve azon alapszik, hogy az ellenállásuk 
megváltozik a hőmérséklettel. A fém ellenállás-hőmérők közül a platina a 
leginkább elterjedt. A félvezető ellenállás-hőmérők (más néven termisztorok) 
attól függően, hogy az ellenállásuk hogyan változik a hőmérséklet 
függvényében, lehetnek NTK (negatív hőmérsékleti együtthatójú) és PTK 
(pozitív hőmérsékleti együtthatójú) változatok. 

Az 5. ábra a hőmérsékletmérés sokrétűségét vázolja. 
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5. ábra Hőmérsékletmérés és érzékelői 

A 6.8. alfejezetben egy változtatható értékű ellenállást (más néven 
potenciométert) használunk feszültségosztóként. A potenciométer egy 
ellenállás szenzor, melynek két fő fajtája: egyenes vonalon mozgó csúszkájú 
és forgó. Ez utóbbi lehet egyfordulatú és többfordulatú. A 6. ábrán egy 
egyfordulatú potenciméter látható. 

Mennyiségek 

Villamos 

Nemvillamos 

Áramerősség Feszültség Ellenállás Egyéb 

Szint Nyomás Hőmérséklet Egyéb 

Érintkezés nélküli 

Érintkezéses 

Fém ellenállás-
hőmérő 

Félvezető 
ellenállás-hőmérő 

(termisztor) 

Hőelem 

 K típusú 

J típusú 

Egyéb 

 

Platina 

Nikkel 

Egyéb 

NTK 

PTK 

Egyéb 
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6. ábra Feszültségosztás potenciométerrel 

1.3. Mérési adatok gyűjtése 

Mérési adatok gyűjtése alatt azt a folyamatot értjük, mely során mérünk egy 
mennyiséget (pl. elektromos feszültség, hőmérséklet) egy erre alkalmas, 
megfelelő szoftverrel támogatott eszközzel (pl. digitális multiméterrel vagy 
adatgyűjtő célhardverrel). 

A multiméter egyetlen műszerként teszi lehetővé több mennyiség mérését is. 
A legalapvetőbb multiméterek olyan elektromos mennyiségek mérésére 
képesek, mint a feszültség, az áramerősség vagy az ellenállás. Egyes 
multiméterek mérni, illetve tesztelni tudják az alábbiakat is: 
• frekvencia, 
• kapacitás, 
• hőmérséklet, 
• dióda, 
• tranzisztor és 
• szakadás. 

Megkülönböztetünk analóg és digitális multimétereket. 

Az analóg multiméter (7. ábra) egy µA mérőt használ és nyomaték-
összehasonlítás elve alapján működik. A műszerre kapcsolt mérendő 
mennyiség hatására a lengőrész elfordul, melynek nyugalmi helyzetében a 
mutató kijelöli a skálán a mért értéket. A működési elvből adódó pontosság, 
a skála leolvasása és a méréshatárváltás emelhető ki az analóg multiméter 
hátrányai közül, míg előnyeként az ára, valamint a feszültségforrás nélküli 
működtetés (kivéve ellenállás mérésekor) említhető meg. 
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7. ábra Voltcraft VC-5070 analóg multiméter 

A digitális multiméter - nevéből adódóan - digitális elv alapján működik és 
integrált áramkörökből épül fel. Egyes digitális multiméterek a hozzá 
kifejlesztett szoftverrel a korábban felsorolt lehetőségeken túl további 
szolgáltatásokat is biztosítanak (pl. mérési adatok gyűjtése (8. ábra)). 

  
8. ábra Adatgyűjtő rendszer digitális multiméterrel 

A digitális mérés elvét (azt a folyamatot, hogy egy analóg értékből hogyan 
lesz egy kijelzőn megjeleníthető érték) a 9. ábra illusztrálja. 
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9. ábra A digitális mérés elve 

A 10. ábrán látható METEX M-32 típusú digitális multiméter és a hozzá 
tartozó Scope View elnevezésű szoftver (11. ábra) lehetőséget nyújt mérési 
adatok fájlba történő mentésére, valamint az adatok megjelenítésére is. 

 

10. ábra METEX M-32 digitális multiméter 
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A METEX M-32 digitális multiméter specifikációi: 
• AC feszültség (400 mV - 750 V), 
• DC feszültség (400 mV - 1000 V), 
• AC áramerősség (4 mA - 20 A), 
• DC áramerősség (4 mA - 20 A), 
• ellenállás (400 Ω - 40 MΩ), 
• hőmérséklet (0 °C - 1000 °C), 
• kapacitás (4 nF - 400 nF), 
• dióda, tranzisztor, szakadás vizsgálat, 
• 3 3/4 digites kijelzés (3999 -es kijelzett érték), 
• 42 szegmenses grafikus analóg kijelző, 
• túlterhelés jelzés, 
• automatikus polaritásváltás és 
• RS-232C interfész. 

A METEX M-32 típusú digitális multiméter RS-232 porton keresztüli 
csatlakozást biztosít a számítógép felé, ezért egy RS232/USB átalakító 
szükséges a kapcsolat kialakításához. 

 

11. ábra Adatmegjelenítés a Scope View szoftver segítségével 

Az adatok (jelen esetben hőmérséklet) egy másodperces időközönként új 
sorba kerülnek a szövegfájlban (12. ábra). 
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12. ábra A szövegfáljba kerülő adatok 

Manapság a digitális multiméterek helyett mérési adatok gyűjtésére szolgáló 
célhardvereket, adatgyűjtőket (DAQ eszközöket) használunk. A teljes 
adatgyűjtő rendszer a szenzor(ok)ból, adatgyűjtőből (pl. NI USB-9211, lásd 
4. fejezet) és számítógépből áll megfelelő szoftvertámogatással (pl. LabVIEW) 
(13. ábra). 

 

13. ábra Adatgyűjtő rendszer DAQ eszközzel 
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A következő fejezetek elsősorban National Instruments adatgyűjtők révén 
korszerű adatgyűjtési, tárolási és megjelenítési lehetőséget mutatnak be 
LabVIEW környezetben. 

Irodalomjegyzék 

1. Dunn P. F.: Measurement, Data Analysis, and Sensor Fundamentals for 
Engineering and Science, CRC Press, Boca Raton, 2011, 614. p. 

2. IDC Technologies: Practical Instrumentation for Automation and Process 
Control for Engineers and Technicians, 2004, 373. p. 

3. Mari L.: Lectures on Measurement Science, Luis Papers, 2004, vol. 157., pp. 
1-38. 

4. Shieh J., Huber J. E., Fleck N. A., Ashby M. F.: The Selection of Sensors, 
Progress in Materials Science, 2001, vol. 46., pp. 461-504. 

5. Siemens: Measuring Technology, Siemens Switzerland Ltd, 86. p. 
(https://www.hqs.sbt.siemens.com/gip/general/dlc/data/assets/hq/Meas
uring-Technology_A6V10208877_hq-en.pdf) (26/08/2013) 

6. Vetelino J., Reghu A.: Introduction to Sensors, CRC Press, Boca Raton, 
2011, 208. p. 

7. http://courses.cs.tamu.edu/rgutier/ceg499_s02/l2.pdf (26/08/2013) 
8. http://physics.nist.gov/Pubs/SP811/sec04.html (26/08/2013) 
9. http://sine.ni.com/np/app/main/p/ap/daq/lang/hu/pg/1/sn/n17:daq/f

mid/652/ (26/08/2013) 
10. http://www.conrad-uk.com/ce/en/product/120285/Voltcraft-VC-5070-

Analogue-Multimeterű (26/08/2013) 
11. http://www.idc-

online.com/technical_references/pdfs/instrumentation/Static%20and%20D
ynamic%20characteristics%20of%20instruments.pdf (26/08/2013) 

12. http://www.tcdirect.hu/deptprod.asp (26/08/2013) 
13. http://www.tequipment.net/MetexME-32.html (26/08/2013) 
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2. HŐMÉRSÉKLET KONVERZIÓ LABVIEW-
BAN 
A National Instruments (NI, www.ni.com) által kifejlesztett LabVIEW 
(Laboratory Virtual Instrumentation Engineering Workbench) szoftver 
oktatási és mérnöki feladatokra egyaránt kiválóan alkalmas a mérés- és 
irányítástechnika területén. 

A LabVIEW programozási nyelve az ún. G programozási nyelv, vagyis 
grafikus úton hajthatjuk végre a programozást. Ez azt jelenti, hogy szöveges 
utasítások helyett ikonok segítségével építhetjük meg az alkalmazásokat. A 
LabVIEW programokat Virtual Instruments (virtuális műszereknek) vagy 
röviden VI-oknak nevezzük. 

Minden LabVIEW programnak két fő felülete van: 
• előlap (Front Panel) és 
• blokk diagram (Block Diagram). 

Az előlap grafikus interfészként szolgál a felhasználó számára, míg a blokk 
diagram a grafikus kódokat és a kapcsolatokat tartalmazza. 

A következő egyszerű LabVIEW modell hőmérséklet konverziót hajt végre: a 
Celsius-fokban megadott értéket átváltja Fahrenheit-fokba, illetve Kelvinbe. 

Manapság három hőmérsékleti skála használatos: Celsius, Kelvin és 
Fahrenheit. A Celsius-skálán a 0 °C a víz fagyáspontját, míg a 100 °C a víz 
forráspontját jelöli. E két pont között tehát 100 osztás található. A Kelvin-
skála szintén 100 osztást tartalmaz e pontok között, de a nullpontja az 
abszolút nulla fokhoz (0 K = -273,15 ºC) tartozik, így a víz fagyáspontja 
273,15 K, míg forráspontja 373,15 K. A Fahrenheit-skála a víz fagyáspontját 
32 °C-ként, míg a forráspontját 212 °C-ként definiálja, ami 180 osztást 
jelent e két nevezetes pont között. 

Az elkészítendő modell tehát a következő két egyenlet megoldását végzi: 

t[°F] = 1,8∙t[°C]+32,  (4) 

T[K] = t[°C]+273,15.  (5) 

Kövessük a következő lépéseket, hogy elkészíthessük a hőmérséklet 
konverziót végrehajtó LabVIEW alkalmazást. 
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Indítsuk el a LabVIEW-t, a Getting Started ablak megjelenik. Ez az ablak 
felhasználható - többek között - új VI készítésére, a legutóbb megnyitott 
alkalmazások listázására, a help funkció indítására, valamint példák 
keresésére is. 

A Getting Started ablak New szakaszában kattintsunk a Blank VI-ra, hogy 
új VI-t készíthessünk. 

 

Mind a front panel, mind a blokk diagram megjelenik. A kettő között a 
Ctrl-E billentyűkombinációval, illetve a Window → Show Front Panel vagy 
Show Block Diagram kiválasztásával tudunk váltani. 

 

Hogy mind a front panel, mind a blokk diagram egyidőben látható legyen, 
válasszuk a következőt: Window → Tile Up and Down. 
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Kattintsunk a jobb egér gombbal a front panelre és válasszuk a Modern → 
Numeric → Numeric Controlt. Helyezzük a numerikus vezérlőt a front 
panelen az egér mozgatásával a kívánt helyre, majd bal egérgomb 
megnyomásával engedjük el. Nevezzük el a numerikus vezérlőt “Degree 
Celsius”-nak. 
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Kattintsunk a jobb egér gombbal a front panelre és válasszuk a Modern → 
Numeric → Numeric Indicatort. Helyezzük el a számkijelzőt a front 
panelen és nevezzük el “Degree Fahrenheit”-nek. Helyezzünk egy újabb 
számkijelzőt is a front panelre és nevezzük el “Kelvin”-nek. 

 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → Numeric → Multiply-t, hogy szorzás funkciót 
helyezhessünk a blokk diagramra. 
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Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → Numeric → Add lehetőséget, hogy összeadás funkciót 
helyezhessünk a blokk diagramra. 

 

Kattintsunk a jobb egér gombbal a szorzás funkció y bemenetére és 
válasszuk a Create → Constant lehetőséget, hogy egy konstanst 
adhassunk a bemenethez. Az értékét állítsuk 1,8-re. 
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Kattintsunk a jobb egér gombbal az összeadás funkció x bemenetére és 
válasszuk a Create → Constant lehetőséget, hogy egy konstanst 
adhassunk ennek a bementére is. Az értékét állítsuk 32-re. 

 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → Numeric → Add lehetőséget, hogy egy újabb összeadás 
funkciót adhassunk a blokk diagramhoz. Az összeadás funkció y 
bemenetéhez adjunk egy konstanst, melynek értéke 273,15. 
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Használjuk a huzalozási eszközt ( ) az összeköttetések kialakításához. Ha 
az egérrel egy objektum be- vagy kimenetére, illetve egy már meglévő 
összeköttetés környezetében mutatunk, akkor a huzalozási eszköz 
automatikusan elérhetővé válik. 

 

Írjunk egy tetszőleges értéket (pl. 100) a Degree Celsius cimkéjű 
numerikus vezérlőbe és nyomjuk meg a Run gombot, hogy tesztelhessük a 
programot. 

 

A “Degree Fahrenheit” és “Kelvin” cimkéjű számkijelzőkben a helyes 
értékeknek kell megjelenniük. 
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Mentsük el a munkánk pl. „Temperature_Conversion” névvel: File → 
Save. 

Zárjuk be a LabVIEW-t. 

Irodalomjegyzék 

1. http://www.ni.com/gettingstarted/labviewbasics/tools.htm 
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3. MÉRÉSI ADATOK GYŰJTÉSE ÉS 
TÁROLÁSA LABVIEW-BAN HARDVER 
NÉLKÜL 
A LabVIEW felhasználható hardver-szoftver integrációra annak érdekében, 
hogy adatokat gyűjthessünk, tárolhassunk, elemezhessünk, illetve 
megjeleníthessünk. Ebben a fejezetben bemutatásra kerül, hogyan 
használható a LabVIEW célhardver nélkül is ezek megvalósítására. 

3.1. Szinusz hullám előállítása 

Indítsuk el a LabVIEW-t, a Getting Started ablak megjelenik. 

A Getting Started ablak New szakaszában kattintsunk a Blank VI-ra, hogy 
új VI-t készíthessünk. 

Hogy mind a front panel, mind a blokk diagram egyidőben látható legyen, 
válasszuk a következőt: Window → Tile Up and Down. 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk az 
Express → Input → Simulate Signalt és helyezzük a VI-t a blokk 
diagramra. 

A Configure Simulate Signal párbeszédablakban változtassuk meg a 
Frequency (Hz)-t 50-re és az Add Noise melletti jelölőnégyzetet pipáljuk ki, 
hogy egy fehér zajt adhassunk a jelünkhöz. Változtassuk meg a Noise 
amplitude lehetőséget 0,5-re, majd kattintsunk az OK-ra. 
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Kattintsunk a jobb egér gombbal a Simulate Signal VI Sine with Uniform 
kimenetére és válasszuk a Create → Graph Indicatort. Ekkor egy grafikus 
kijelző jelenik meg a front panelen. 

Futtassuk a programot (Run). A jel látható lesz a grafikus kijelzőn. 
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3.2. Statisztikai analízis végzése a gyűjtött adatokon 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk az 
Express → Signal Analysis → Statistics lehetőséget, hogy egy Statistics 
VI-t helyezhessünk a blokk diagramra. 

A Configure Statistics párbeszédablakban válasszuk a Root mean square 
(RMS), Maximum, Minimum és Range (maximum - minimum) 
lehetőségeket. Kattintsunk az OK-ra, hogy bezárhassuk a párbeszédpanelt. 

 

Kössük össze a Statistics VI Signals bemenetét a Simulate Signal VI és a 
grafikus kijelző közötti összeköttetéssel a huzalozási eszköz segítségével. 
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Kattintsunk a jobb egér gombbal a Statistics VI RMS, Maximum, 
Minimum és Range kimeneteire és válasszuk a Create → Numeric 
Indicatort, majd nyomjuk meg a Run gombot. A statisztikai értékek 
megjelennek a front panelen. 
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3.3. Adatok mentése fájlba 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → File I/O → Write to Measurement File-t, hogy ezt a VI-t 
a blokk diagramra helyezhessünk. 

A Configure Write To Measurement File párbeszádablakból kiindulva 
válasszunk egy helyet (ha kell, készítsünk) és fájlnevet (pl. Sine), amibe 
elmenthetjük az adatokat, majd állítsuk az If a file already exists 
lehetőséget Overwrite file-ra, végezetül nyomjuk meg az OK gombot. 

 

Kössük össze a Write to Measurement File VI Signals bemenetét a 
Simulate Signal VI és a grafikus kijelző közötti összeköttetéssel a 
huzalozási eszköz segítségével, majd futtassuk a VI-t (Run). 
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Mentsük el a munkánk pl. „Sine_SW” névvel: File → Save. 

Zárjuk be a LabVIEW-t. 

Nyissuk meg az adatfájlt (Sine.lvm) pl. Jegyzettömbbel és győződjünk meg 
arról, hogy tartalmaz adatokat. A minták számának 100-nak kell lennie. Ez 
az érték módosítható a Configure Simulate Signal párbeszédablakban, 
mely elérhető a Simulate Signal VI-ra történő kettős kattintással. 

Zárjuk be a Jegyzettömböt. 
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4. MÉRÉS NI USB-9211 HARDVERREL 
LABVIEW SIGNALEXPRESS 
KÖRNYEZETBEN 
A LabVIEW SignalExpress egy interaktív, adatnaplózási lehetőséget biztosító 
szoftver adatgyűjtő eszközökből érkező adatok gyors gyűjtéséhez, 
elemzéséhez és megjelenítéséhez. Ebben a fejezetben bemutatásra kerül, 
hogyan használható a LabVIEW SignalExpress egy NI USB-9211 típusú 
célhardverrel. 

4.1. NI USB-9211 bemeneti modul termoelemekhez 

Az NI USB-9211 adatgyűjtő négy darab 24 bites bemenetet biztosít 
termoelemek számára integrált jelkondícionálással. Az adatgyűjtő két 
összetevőből áll: egy NI 9211-es modulból és egy NI USB-9161-es jelzésű 
keretből (14. ábra). 

  
14. ábra NI USB-9211 adatgyűjtő és terminál blokkja 

Specifikációk: 
• 4 darab bemenet termoelemek számára, 
• 24 bites felbontás, 
• 14 S/s mintavételezés, 
• beépített hidegpont kompenzáció, 
• kompatibiltás K, R, S, T, N, E és B típusú hőelemekkel és 
• plug-and-play kapcsolat USB-n keresztül. 
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Kövessük a következő lépéseket, hogy konfigurálhassuk és tesztelhessük az 
ismertetett adatgyűjtőt, illetve készíthessünk egy taszkot (ami egy vagy több 
virtuális csatorna gyűjteményét jelenti), amelyet felhasználunk LabVIEW 
SignalExpres környezetben. 

4.2. Az NI USB-9211 konfigurálása és tesztelése 

Illesszünk egy K típusú hőelemet a terminál blokkhoz (TC0+ és TC0-) és 
csatlakoztassuk az adatgyűjtőt a számítógéphez. Ekkor az adatgyűjtőn 
található LED folyamatosan villog. 

Válasszuk a Configure and Test This Device-t a New Data Acquisition 
Device ablakban, majd kattintsunk az OK-ra vagy indítsuk el a 
Measurement & Automation Explorer (MAX) programot. 

 

Nyissuk ki a Devices and Interfaces, majd a NI-DAQmx Devices 
lehetőséget (ha szükséges). Ellenőrizzük, hogy az NI USB-9211A: „Dev…” 
megjelenik a listában, ha nem, akkor nyomjuk meg az F5 gombot. 
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Kattintsunk a jobb egér gombbal az NI USB-9211A: „Dev…” lehetőségre és 
a válasszuk a Test Panels… opciót, hogy egy tesztet futtathassunk, majd 
kattintsunk a Start gombra. 

 

Ha a teszt sikeresen lefutott, nyomjuk meg a Stop, majd a Close gombot. 
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Kattintsunk a jobb egér gombbal az NI USB-9211A: „Dev…” lehetőségre és 
válasszuk a Device Pinouts opciót, hogy megtekinthessük az eszközünk 
lábkiosztását. 

 

Zárjuk be az ablakot. 

4.3. Taszk készítése a hőelem számára 

Kattintsunk a jobb egér gombbal az NI USB-9211A: „Dev…” lehetőségre és 
válasszuk a Create Task… opciót. 

A Create New NI-DAQmx Task… párbeszédablakban válasszuk az Acquire 
Signals → Analog Input → Temperature → Thermocouple-t. 
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Válasszuk ki az ai0-t, majd kattintsunk a Next gombra. 

 

Írjuk be a taszk nevét: Thermocouple, majd kattintsunk a Finish gombra. 
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A Thermocouple taszk megjelenik a Data Neighborhood/NI-DAQmx 
Tasks listában. 

 

Állítsuk a Thermocouple Type lehetőséget K-ra és futtassuk a programot 
(Run). 
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Az aktuális hőmérséklet értéke megjelenik. Nyomjuk meg a Stop gombot. 

 

Mentsük el a beállítást (Save), ami a későbbiekben felhasználható lesz az 
alkalmazásokhoz. 
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4.4. A “Thermocouple” Taszk használata LabVIEW 
SignalExpress környezetben 

A MAX-ben nyissuk ki a Software lehetőséget, kattintsunk a jobb egér 
gombbal a LabVIEW SignalExpressre, majd kattintsunk a Launch 
LabVIEW SignalExpressre. 

 

Válasszuk ki a Tools → Import NI-DAQmx Task from MAX… lehetőséget, 
hogy a Thermocouple taszkot importálhassuk. Az Import NI-DAQmx Task 
from MAX ablakban válasszuk a Thermocouple-t és kattintsunk az OK-ra. 

 

Állítsuk a Sample Period (s) lehetőséget 1-re és váltsunk a Step Setup 
ablakról Data View ablakra. 
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Húzzuk a Thermocouple-t a Data View ablakba, majd kattintsunk a Run 
gombra, hogy ellenőrizhessük a beállításokat. 

 

Az aktuális hőmérséklet értéke grafikusan megjelenik. A leállításhoz 
nyomjuk meg a Stop gombot. 
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Más megjelenítési mód (pl. tartály, csúszka) is kiválasztható. Ehhez 
kattintsunk a jobb egér gombbal a Data View ablakra és válasszuk a View 
As opciót. 

Adatok rögzítéséhez kattintsunk a Record gombra, majd válasszuk a 
Thermocouple-t a Logging Signals Selection ablakban. Változtassuk meg 
a nevet First testre, majd kattintsunk az OK gombra. 
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A rögzítés megállításához nyomjuk meg a Stop gombot és ha szükséges, az 
OK gombot. 
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A rögzített adatok megtekintéséthez váltsunk Monitor/Record módról 
Playback módra a First test napló kiválasztásával, majd a képernyő alján 
lévő First test naplót húzzuk a Data View ablakba és futtassuk azt (Run). 
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Ha a futtatást a vége előtt szeretnénk leállítani, nyomjuk meg a Stop 
gombot. 

 

Mentsük el a munkánk pl. „Thermocouple1_SE” névvel: File → Save 
Project. 

Az adatok Microsoft Excelbe történő exportálásához kattintsunk a jobb 
egér gombbal Data View ablakra és válasszuk az Export To → Microsoft 
Excel lehetőséget. Mentsük el az így kapott fájlt pl. 
„Thermocouple1_Excel” névvel. 

Zárjuk be a Microsoft Excel és LabVIEW SignalExpress programokat. 

4.5. Két csatorna használata LabVIEW SignalExpress 
környezetben 

Illesszünk egy újabb K típusú hőelemet a terminál blokkhoz (TC1+ és 
TC1-). Válasszuk a Thermocouple taszkok, majd az Add Channels → 
Thermocouple opciót a MAX-ben. 
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Válasszuk ki az ai1-et az Add Channels To Task ablakban, majd 
kattintsunk az OK-ra. 

  

A Temperature_0 csatorna megjelenik. 
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Nyomjuk meg a Run gombot. A hőmérséleti értékek megjelennek. Nyomjuk 
meg a Stop gombot és mentsük el az új beállításokat (Save). 

Indítsuk el a LabVIEW SignalExpress programot. Válasszuk a Tools → 
Import NI-DAQmx Task from MAX… lehetőséget, hogy a Thermocouple 
taszkot importálhassuk. Az Import NI-DAQmx Task from MAX ablakban 
válasszuk a Thermocouple taszkot és kattintsunk az OK-ra. 

Állítsuk a Sample Period (s) lehetőséget 1-re és váltsunk a Step Setup 
ablakról Data View ablakra. Kétszer kattintsunk az Add Display gombra. 
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Nyissuk ki a DAQmx Acquire alatt megjelenő Thermocouple-t és húzzuk a 
Temperature-t az első Data View ablakba, a Temperature_0-t a második 
Data View ablakba, míg a teljes Thermocouple-t a harmadik Data View 
ablakba. Nyomjuk meg a Run gombot a futtatáshoz. A két termoelem által 
szolgáltatott értékek külön-külön, illetve együtt is megjelennek. 

 

Nyomjuk meg a Stop gombot és mentsük el a munkánk pl. 
„Thermocouple2_SE” névvel: File → Save Project. 

Zárjuk be a LabVIEW SignalExpress és MAX programokat. 

Irodalomjegyzék 

1. User Guide and Specifications - NI USB-9211/9211A 
2. http://www.ni.com/labview/signalexpress/ (26/08/2013) 
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5. MÉRÉSI ADATOK GYŰJTÉSE ÉS 
TÁROLÁSA LABVIEW-BAN NI USB-9211 
ADATGYŰJTŐVEL 
Ahogy a 3. fejezetben szerepelt, a LabVIEW felhasználható hardver-szoftver 
integrációra annak érdekében, hogy adatokat gyűjthessünk, tárolhassunk, 
elemezhessünk, illetve megjeleníthessünk. Ebben a fejezetben bemutatásra 
kerül, hogyan használható a LabVIEW célhardverrel ezek megvalósítására. 

5.1. A hardver-szoftver integráció konfigurálása 

Illesszünk egy K típusú hőelemet a terminál blokkhoz (TC0+ és TC0-) és 
csatlakoztassuk az adatgyűjtőt a számítógéphez. Ekkor az adatgyűjtőn 
található LED folyamatosan villog. 

Válasszuk a Configure and Test This Device-t a New Data Acquisition 
Device ablakban, majd kattintsunk az OK-ra vagy indítsuk el a 
Measurement & Automation Explorer (MAX) programot. 

Nyissuk ki a Devices and Interfaces, majd a NI-DAQmx Devices 
lehetőséget (ha szükséges). Ellenőrizzük, hogy az NI USB-9211A: „Dev…” 
megjelenik a listában, ha nem, akkor nyomjuk meg az F5 gombot. 

Indítsuk el a LabVIEW-t, a Getting Started ablak megjelenik. 

A Getting Started ablak New szakaszában kattintsunk a Blank VI-ra, hogy 
új VI-t készíthessünk. 

Hogy mind a front panel, mind a blokk diagram egyidőben látható legyen, 
válasszuk a következőt: Window → Tile Up and Down. 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx→ DAQ Assistant lehetőséget és helyezzük 
a VI-t a blokk diagramra. 

A Create New Express Task… párbeszédablakban válasszuk az Acquire 
Signals → Analog Input → Temperature → Thermocouple-t. 
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Válasszuk ki ai0-t analóg bemeneti csatornának, majd kattintsunk a Finish 
gombra. 

 

 



53 

 

Állítsuk a Thermocouple Type lehetőséget K-ra, az Acquisition Mode-ot N 
Samples-re, a Samples to Readet 20-ra, a Rate (Hz) lehetőséget 10-re és 
futtassuk a programot (Run). 

 

Az aktuális hőmérsékleti érték megjelenik. 

 

Kattintsunk az OK gombra. 
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Kattintsunk a jobb egér gombbal a DAQ Assistant data kimenetére és 
válasszuk a Create → Graph Indicatort. Egy grafikus kijelző megjelenik a 
front panelen. Futtassuk a programot (Run). Az adatok (20 darab) 
kirajzolódnak a grafikus kijelzőn. 
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5.2. Statisztikai számítások végzése a gyűjtött 
adatokon 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk az 
Express → Signal Analysis → Statistics lehetőséget, hogy egy Statistics 
VI-t helyezhessünk a blokk diagramra. 

A Configure Statistics párbeszédablakban válasszuk a Root mean square 
(RMS), Maximum, Minimum és Range (maximum - minimum) 
lehetőségeket. Kattintsunk az OK-ra, hogy bezárhassuk a párbeszédpanelt. 

 

Kössük össze a Statistics VI Signals bemenetét a DAQ Assistant VI és a 
grafikus kijelző közötti összeköttetéssel a huzalozási eszköz segítségével. 

 

Kattintsunk a jobb egér gombbal a Statistics VI RMS, Maximum, 
Minimum és Range kimeneteire és válasszuk a Create → Numeric 
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Indicatort, majd nyomjuk meg a Run gombot. A statisztikai értékek 
megjelennek a front panelen. 

  

5.3. Adatok írása fájlba 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → File I/O → Write to Measurement File-t, hogy ezt a VI-t 
a blokk diagramra helyezhessünk. 

A Configure Write To Measurement File párbeszádablakból kiindulva 
válasszunk egy helyet (ha kell, készítsünk) és fájlnevet (pl. Thermocouple), 
amibe elmenthetjük az adatokat, majd állítsuk az If a file already exists 
lehetőséget Overwrite file-ra, végezetül nyomjuk meg az OK gombot. 
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Kössük össze a Write to Measurement File VI Signals bemenetét a DAQ 
Assistant VI és a grafikus kijelző közötti összeköttetéssel a huzalozási 
eszköz segítségével, majd futtassuk a VI-t (Run). 
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Mentsük el a munkánk pl. „Thermocouple_HW” névvel: File → Save. 

Zárjuk be ezt a VI-t. 

Nyissuk meg az adatfájlt (Thermocouple.lvm) pl. Jegyzettömbbel és 
győződjünk meg arról, hogy tartalmaz adatokat. A minták számának 20-nak 
kell lennie. Ez az érték módosítható a DAQ Assistant VI-ra történő kettős 
kattintással. 

Zárjuk be a Jegyzettömböt. 

5.4. Adatok folyamatos írása fájlba 

Nyissunk meg egy új VI-t. 

Hogy mind a front panel, mind a blokk diagram egyidőben látható legyen, 
válasszuk a következőt: Window → Tile Up and Down. 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk az 
Express → Exec Control → While Loop lehetőséget, hogy egy while ciklust 
hozhassunk létre. Rajzoljunk ennek elérésére egy téglalapot. 
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Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx → Start lehetőséget, hogy egy Start VI-t 
helyezhessünk a blokk diagramra. 

 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx → Stop lehetőséget, hogy egy Stop VI-t 
helyezhessünk a blokk diagramra. 

 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx → Read lehetőséget, hogy egy Read VI-t 
helyezhessünk a blokk diagramra. 
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Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx → Task Const lehetőséget, hogy egy Task 
Const VI-t helyezhessünk a blokk diagramra. 

 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → File I/O → Write to Measurement File-t, hogy ezt a VI-t 
a blokk diagramra helyezhessünk. 

A Configure Write To Measurement File párbeszádablakból kiindulva 
válasszunk egy helyet (ha kell, készítsünk) és fájlnevet (pl. 
Thermocouple1), amibe elmenthetjük az adatokat, majd állítsuk az If a file 
already exists lehetőséget Overwrite file-ra, végezetül nyomjuk meg az OK 
gombot. 
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Kattintsunk a jobb egér gombbal a front panelre és válasszuk az 
Express → Graph Indicators → Waveform Chart lehetőséget, hogy egy 
grafikus kijelzőt helyezhessünk a front panelre. A grafikus kijelző 
megjelenik a front panelen. 
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Kössük össze a huzalozási eszköz segítségével: 
• a Start VI task out kimenetét a Read VI task/channels in 

bemenetével, 
• a Start VI error out kimenetét a Read VI error in bemenetével, 
• a Read VI task out kimenetét a Stop VI task/channels in bemenetével, 
• a Read VI error out kimenetét a Stop VI error in bemenetével, 
• a Task Const VI-t a Start VI task/channels in bemenetével, 
• a Read VI data kimenetét a Write to Measurement File VI Signals 

bementével és 
• a grafikus kijelzőt a Write to Measurement File VI Signals 

bemenetével. 
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Készítsünk egy új taszkot a Task Const VI kapcsolásával és válasszuk a 
Browse lehetőséget. A Thermocouple taszk megjelenik. Kattintsunk a 
Create New… opcióra és válasszuk a MAX Task lehetőséget. 
 

 

A Create New NI-DAQmx Task… párbeszédablakban válasszuk az Acquire 
Signals → Analog Input → Temperature → Thermocouple-t, utána az 
ai0-t, majd kattintsunk a Next gombra. Írjuk be a taszk nevét: 
Thermocouple1, majd kattintsunk a Finish gombra. 
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Állítsuk a Thermocouple Type lehetőséget K-ra és nyomjuk meg a Run 
gombot. Az aktuális hőmérsékleti érték megjelenik. Kattintsunk a Stop 
gombra, majd az OK-ra. Válasszuk ki a Thermocouple1 taszkot a Select 
item(s) ablakban, majd kattintsunk az OK-ra. 

 

Nyomjuk meg a Run gombot. A helyes hőmérsékleti érték folyamatosan 
kirajzolódik. 
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Nyomjuk meg a STOP gombot a leállításhoz. 

 

A Thermocouple1 taszk megjelenik a Data Neighborhood/NI-DAQmx 
Tasks listában. 

  

Mentsük el a munkánk pl. „Thermocouple_HW1” névvel: File → Save. 

Zárjuk be a LabVIEW és MAX programokat. 

Nyissuk meg az adatfájlt (Thermocouple1.lvm) pl. Jegyzettömbbel és 
győződjünk meg arról, hogy tartalmaz adatokat. 

Zárjuk be a Jegyzettömböt. 
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6. ADATGYŰJTÉS NI USB-6009 
MULTIFUNKCIÓS I/O ESZKÖZZEL 
Ebben a fejezetben bemutatásra kerül az NI USB-6009 multifunkciós I/O 
eszköz, annak konfigurálása, tesztelése és alapvető alkalmazási lehetőségei 
LabVIEW környezetben. 

6.1. NI USB-6009 multifunkciós I/O eszköz 

Az NI USB-6009 multifunkciós I/O eszköz (15. ábra) különféle 
alkalmazások számára biztosít adatgyűjtési lehetőséget. 

  

15. ábra NI USB-6009 adatgyűjtő és terminál blokkja 

Specifikációk: 
• 8 analóg bemenet (14-bit, 48 kS/s), 
• 2 analóg kimenet (12-bit, 150 S/s), 
• 12 digitális I/O, 
• 32 bites számláló, 
• digitális triggerelés és 
• bus-powered. 

Az NI USB-6009 adatgyűjtő blokk diagramját a 16. ábra szemlélteti. 
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16. ábra Az NI USB-6009 adatgyűjtő blokk diagramja 

GND: földelés - referencia pont. 

AI <0..7>: analóg bemeneti csatornák. 

AO <0, 1>: analóg kimeneti csatornák. 

P0.<0..7>: digitális I/O csatornák. 

P1.<0..3>: digitális I/O csatornák. 

PFI 0: PFI 0, mely konfigurálható, mint digitális trigger vagy számláló 
bemenet. 

+2,5 V: +2,5 V külső referencia. 

+5 V: +5 V tápfeszültség forrás. 

A 6. táblázat az analóg, míg a 7. táblázat a digitális terminál kiosztását 
mutatja. 
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6. táblázat Analóg terminál kiosztása 

 

7. táblázat Digitális terminál kiosztása 

 
 

Modul Terminál Asz. mód Diff. mód 

Modul Terminál Jel 
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6.2. Az NI USB-6009 konfigurálása és tesztelése 

Csatlakoztassuk az „AI0+” csatornát az „AO0” csatornához, illetve az „AI0-” 
csatornát a „GND” csatornához a 17. ábra szerint, majd csatlakoztassuk az 
adatgyűjtőt a számítógéphez. Ekkor az adatgyűjtőn található LED 
folyamatosan villog. 

 

17. ábra A csatornák összekötése 

Válasszuk a Configure and Test This Device-t a New Data Acquisition 
Device ablakban, majd kattintsunk az OK-ra vagy indítsuk el a 
Measurement & Automation Explorer (MAX) programot. 

Nyissuk ki a Devices and Interfaces, majd a NI-DAQmx Devices 
lehetőséget (ha szükséges). Ellenőrizzük, hogy az NI USB-6009: „Dev…” 
megjelenik a listában, ha nem, akkor nyomjuk meg az F5 gombot. 
 

 

Kattintsunk a jobb egér gombbal az NI USB-6009: „Dev…” lehetőségre és a 
válasszuk a Test Panels… opciót, hogy egy tesztet futtathassunk, majd 
kattintsnuk a Start gombra. 
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Válasszuk az Analog Output fület, állítsunk be pl. 2,35-ot, mint Output 
Value, majd kattintsunk az Update gombra. 

  

Térjünk vissza az Analog Input fülre és kattintsunk a Start gombra. 
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Ha a teszt sikeresen lefutott, nyomjuk meg a Stop, majd a Close gombot. 

  

Kattintsunk a jobb egér gombbal az NI USB-6009: „Dev…” lehetőségre és 
válasszuk a Device Pinouts opciót, hogy megtekinthessük az eszközünk 
lábkiosztását. 

 

Zárjuk be az ablakot. 
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6.3. Taszk készítése feszültség jel fogadására 

Kattintsunk a jobb egér gombbal az NI USB-6009: „Dev…” lehetőségre és 
válasszuk a Create Task… opciót. 

A Create New NI-DAQmx Task… párbeszédablakban válasszuk az Acquire 
Signals → Analog Input → Voltage lehetőséget. 

 

Válasszuk ki az ai0-t, majd kattintsunk a Next gombra. 

  

Írjuk be a taszk nevét: Voltage, majd kattintsunk a Finish gombra. 
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A Voltage taszk megjelenik a Data Neighborhood/NI-DAQmx Tasks 
listában. 

 

 

Állítsuk a Max of Signal Input Range lehetőséget 5-re, a Min of Signal 
Input Range lehetőséget 0-ra, az Acquisition Mode lehetőséget 1 Sample 
(On Demand)-ra és futtassuk a programot (Run). 
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A beállított feszültség értéke (~2,35) megjelenik. Nyomjuk meg a Stop 
gombot. 

  

Mentsük el a beállítást (Save), ami a későbbiekben felhasználható lesz az 
alkalmazásokhoz. 
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6.4. A “Voltage” taszk használata LabVIEW-ban 

Nyissuk meg a Thermocouple_HW1 LabVIEW fájlt, majd válasszuk ki a 
Voltage taszkot a Task Const VI átkapcsolásával. 

 

Kattintsunk kettőt a Write to Measurement File VI-ra. A Configure Write 
To Measurement File párbeszádablakból kiindulva válasszunk egy helyet 
(ha kell, készítsünk) és fájlnevet (pl. Voltage), amibe elmenthetjük az 
adatokat, majd nyomjuk meg az OK gombot. 
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Mentsük el a munkánk pl. „Voltage” névvel: File → Save as → Substitute 
copy for original. 

Nyomjuk meg a Run gombot. A beállított feszültség értéke (~2,35) 
folyamatosan kijelzésre kerül. 

  

A leállításhoz nyomjuk meg a STOP gombot. 

  

Nyissuk meg az adatfájlt (Voltage.lvm) pl. Jegyzettömbbel és győződjünk 
meg arról, hogy tartalmaz adatokat. 

Zárjuk be a Jegyzettömböt és ezt a VI-t. 
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6.5. Taszk készítése analóg bemenethez DAQ Assistant 
segítségével 

Kattintsunk a jobb egér gombbal az NI USB-6009: „Dev…” lehetőségre a 
MAX programban és válasszuk a Test Panels… opciót, hogy egy tesztet 
futtathassunk. Válasszuk az Analog Output fület, állítsunk be pl. 4,5-et, 
mint Output Value, majd kattintsunk az Update gombra. Térjünk vissza az 
Analog Input fülre és kattintsunk a Start gombra. Ha a teszt sikeresen 
lefutott, nyomjuk meg a Stop, majd a Close gombot. 

Nyissunk meg egy új VI-t. Hogy mind a front panel, mind a blokk diagram 
egyidőben látható legyen, válasszuk a következőt: Window → Tile Up and 
Down. 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx→ DAQ Assistant lehetőséget és helyezzük 
a VI-t a blokk diagramra. 

A Create New Express Task… párbeszédablakban válasszuk az Acquire 
Signals → Analog Input → Voltage lehetőséget. 

Válasszuk ki az ai0-t, majd kattintsunk a Finish gombra. 

Állítsuk a Max of Signal Input Range lehetőséget 5-re, a Min of Signal 
Input Range lehetőséget 0-ra, az Acquisition Mode lehetőséget 1 Sample 
(On Demand)-ra és futtassuk a programot (Run). A beállított feszültség 
értéke (~4,5) megjelenik. Nyomjuk meg a Stop, majd az OK gombot. 

 

Kattintsunk a jobb egér gombbal a DAQ Assistant data kimenetére és 
válasszuk a Create → Numeric Indicatort. Egy számkijelző megjelenik a 
front panelen. Futtassuk a programot (Run). A beállított feszültség érték 
(~4,5) megjelenik a számkijelzőn. 
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Nevezzük el a számkijelzőt “Voltage”-nak. 
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Használjunk while ciklust az NI USB-6009 eszközből történő folyamatos 
olvasáshoz. Kattintsunk a jobb egér gombbal a blokk diagramra és 
válasszuk az Express → Exec Control → While Loop lehetőséget, hogy egy 
while ciklust hozhassunk létre. Rajzoljunk ennek elérésére egy téglalapot a 
DAQ Assistant VI és a numerikus kijelző köré. 

 

Nyomjuk meg a Run gombot. A beállított feszültség értéke (~4,5) 
folyamatosan kijelzésre kerül. A leállításhoz nyomjuk meg a STOP gombot. 

 

Mentsük el a munkánk pl. „Voltage_Input” névvel: File → Save. 

Zárjuk be ezt a VI-t. 
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6.6. Taszk készítése analóg kimenethez DAQ Assistant 
segítségével 

Nyissunk meg egy új VI-t. Hogy mind a front panel, mind a blokk diagram 
egyidőben látható legyen, válasszuk a következőt: Window → Tile Up and 
Down. Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx→ DAQ Assistant lehetőséget és helyezzük 
a VI-t a blokk diagramra. 

A Create New Express Task… párbeszédablakban válasszuk a Generate 
Signals → Analog Output → Voltage lehetőséget. 

 

Válasszuk ki az ao0-t, majd kattintsunk a Finish gombra. 
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Végezetül nyomjuk meg az OK gombot. 

 

Kattintsunk a jobb egér gombbal a front panelre és válasszuk az Express 
→ Num Ctrls → Num Ctrl lehetőséget. A numerikus vezérlő megjelenik a 
front panelen. Nevezzük el “ Voltage Output”-nak. 

 

Kössük össze a DAQ Assistant VI data bemenetét a numerikus vezérlővel 
a huzalozási eszköz segítségével. 
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Írjunk be egy tetszőleges értéket (pl. 3) és nyomjuk meg a Run gombot. 

 

Futtassuk a Voltage_Input.vi programot (Run). A beállított feszültség 
értéke (~3) megjelenik. Nyomjuk meg a STOP gombot. 

  

  

Használjunk while ciklust az NI USB-6009 eszközbe történő folyamatos 
íráshoz. Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk 
az Express → Exec Control → While Loop lehetőséget, hogy egy while 
ciklust hozhassunk létre. Rajzoljunk ennek elérésére egy téglalapot a DAQ 
Assistant VI és a numerikus vezérlő köré. 
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Futtassuk mindkét programot (Run). A beállított feszültség értéke (~3) 
folyamatosan kijelzésre kerül és módosítható. A leállításhoz nyomjuk a 
STOP gombokat. 

Mentsük el a munkánk pl. „Voltage_Output” névvel: File → Save. 

Zárjuk be ezt a VI-t. 

6.7. Komplex fájl I/O művelet 

Használjuk a Voltage_Output.vi LabVIEW fájlt. 

Nagyítsuk meg a while ciklust jelző téglalapot. 
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Másoljuk át a Start VI, Stop VI, Read VI, Task Const VI és Waveform 
Chart ikonokat a Voltage.vi fájlból. (SHIFT+bal egér gomb az ikonokra, 
majd Edit → Copy (vagy CTRL+C) és Edit → Paste (vagy CTRL+V).) 
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Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → File I/O → Format into File-t. 

 

Nagyítsuk meg a Format into File-t, hogy 4 darab bemenet jelenjen meg 
(input 1, input 2, input 3 és input 4). Kattintsunk a jobb egér gombbal a 
blokk diagramra és válasszuk a Programming → File I/O → 
Open/Create/Replace File-t. 
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Kattintsunk a jobb egér gombbal az Open/Create/Replace File file path 
(use dialog) bemenetére és válasszuk a Create → Controlt. 

Kattintsunk a jobb egér gombbal az Open/Create/Replace File operation 
(0: open) bemenetére és válasszuk a Create → Constant lehetőséget, amit 
állítsunk át replace or create-re. 

 

Egy mező a fájl megadására megjelenik a front panelen. 
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Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → File I/O → Close File-t. 

 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → Timing → Wait Until Next ms Multiple-t. 
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Kattintsunk a jobb egér gombbal a Wait Until Next ms Multiple 
millisecond multiple bemenetére és válasszuk a Create → Controlt, majd 
helyezzük a vezérlőt a while cikluson kívülre. 

 

Egy új vezérlő megjelenik a front panelen. 

 

Helyezzünk egy szorzás funkciót a blokk diagramra: kattintsunk a jobb 
egér gombbal a blokk diagramra és válasszuk a Programming → Numeric 
→ Multiply-t. 
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Annak érdekében, hogy az adatokat külön sorokban láthassuk majd, 
kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Programming → String → Tab Constant, majd a Programming → String 
→ End of Line Constant lehetőségeket. 
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Kössük össze a huzalozási eszköz segítségével: 
• a Start VI task out kimenetét a Read VI task/channels in 

bemenetével, 
• a Start VI error out kimenetét a Read VI error in bemenetével, 
• a Read VI task out kimenetét a Stop VI task/channels in bemenetével, 
• a Read VI error out kimenetét a Stop VI error in bemenetével, 
• a Task Const VI-t a Start VI task/channels in bemenetével, 
• a millisecond multiple controlt a While Until Next ms Multiple 

ikonnal, 
• az Open/Create/Replace File refnum out kimenetét a Format into 

File input file bemenetével, 
• az Open/Create/Replace File error out kimenetét a Format into File 

error in bemenetével, 
• a Format into File output file refnum kimenetét a Close File refnum 

bemenetével, 
• a Format into File error out kimenetét a Close File error in 

bemenetével, 
• szorzás funkció x bemenetét a millisecond multiple control és a While 

Until Next ms Multiple közötti összeköttetéssel, 
• a Loop iteration ikont a szorzás funkció y bemenetével, 
• a szorzás funkció x*y kimenetét a Format into File input 1 

bemenetével, 
• a Tab Constant ikont a Format into File input 2 bemenetével, 
• a Read VI data kimenetét a Format into File input 3 bemenetével, 
• a grafikus kijelzőt a Read VI és a Format into File input 3 bemenete 

közötti összeköttetéssel és 
• az End of Line Constant ikont a Format into File input 4 

bemenetével. 
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Mentsük el a munkánk pl. „Voltage_Input_Output” névvel: File → Save as 
→ Substitute copy for original. 

Válasszunk egy helyet (ha kell, készítsünk) és fájlt (pl. 
Voltage_Input_Output.txt), amibe elmenthetjük az adatokat. Állítsunk be 
pl. 3-at, mint Voltage Output és pl. 100-at, mint millisecond multiple, 
majd futtassuk a VI-t (Run). 

 

A beállított feszültség értéke (~3) kirajzolódik a grafikus kijelzőn. A 
leállításhoz nyomjuk meg a STOP gombot. 
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Nyissuk meg a Voltage_Input_Output.txt fájlt pl. Jegyzettömbbel, hogy 
ellenőrizhessük a munkánkat. Az adatok 100 ms-onként új sorban 
jelennek meg. 

 

Zárjuk be a Jegyzettömböt. 

Annak érdekében, hogy az idő másodpercben kerüljön rögzítésre, egy osztás 
funkciót is beépítünk. Kattintsunk a jobb egér gombbal a blokk diagramra 
és válasszuk a Programming → Numeric → Divide lehetőséget. 

Töröljük a Multiply x bementéhez tartozó összeköttetést. Kattintsunk a 
jobb egér gombbal az osztás funkció y bemenetére és válasszuk a Create → 
Constant lehetőséget, hogy egy konstanst adhassunk ehhez a bemenethez, 
melynek értéke 1000. 

Kössük össze az osztás funkció x bemenetét a millisecond multiple 
control és a While Until Next ms Multiple közötti összeköttetéssel a 
huzalozási eszköz segítségével, majd az osztás funkció x/y kimenetét a 
szorzás funkció x bemenetével. 
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Futtassuk a VI-t (Run), a leállításhoz pedig nyomjuk meg a STOP gombot. 
Nyissuk meg a Voltage_Input_Output.txt fájlt pl. Jegyzettömbbel. Az 
adatok továbbra is 100 ms-onként, de másodperc formátumban jelennek 
meg. 

 

Nevezzük el a front panel elemeit. 
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A blokk diagram elrendezéséhez nyomjuk meg a Clean Up Diagram 
gombot. 

 

Mentsük el a munkánk: File → Save. 

Zárjuk be a VI-okat és a Jegyzettömböt. 

6.8. Taszk készítése potenciométerrel előállított 
feszültség jel fogadására 

Illesszünk egy potentiométert a terminál blokkhoz a 18. ábra szerint, 
majd csatlakoztassuk az adatgyűjtőt a számítógéphez. Ekkor az 
adatgyűjtőn található LED folyamatosan villog. 
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18. ábra A potenciométer illesztése az adatgyűjtőhöz 

Nyissunk meg egy új VI-t. Hogy mind a front panel, mind a blokk diagram 
egyidőben látható legyen, válasszuk a következőt: Window → Tile Up and 
Down. 

Kattintsunk a jobb egér gombbal a blokk diagramra és válasszuk a 
Measurement I/O → NI-DAQmx→ DAQ Assistant lehetőséget és helyezzük 
a VI-t a blokk diagramra. 

A Create New Express Task… párbeszédablakban válasszuk az Acquire 
Signals → Analog Input → Voltage lehetőséget. 

Válasszuk az ai0-t, majd kattintsunk a Next gombra. 

Állítsuk a Max of Signal Input Range lehetőséget 5-re, a Min of Signal 
Input Range lehetőséget 0-ra, a Terminal Configuration lehetőséget RSE-
re és futtassuk a programot (Run). A kijelzett feszültség értéknek 5-nél 
kisebbnek kell lennie. 

+5V AI0+  GND 
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A feszültség értéke a potentiométerrel változtatható. 
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Végezetül kattintsunk az OK gombra. 

Kattintsunk a jobb egér gombbal a front panelre és válasszuk az Express 
→ Graph Indicators → Waveform Chart lehetőséget, hogy egy grafikus 
kijelzőt helyezhessünk a front panelre. A grafikus kijelző megjelenik a 
front panelen. 

Kössük össze a DAQ Assistant VI data kimenetét a grafikus kijelzővel a 
huzalozási eszköz segítségével. 

Nyomjuk meg a Run gombot, hogy tesztelhessük a programot. 
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Használjunk while ciklust folyamatos olvasáshoz. Kattintsunk a jobb egér 
gombbal a blokk diagramra és válasszuk az Express → Exec Control → 
While Loop lehetőséget, hogy egy while ciklust hozhassunk létre. 
Rajzoljunk ennek elérésére egy téglalapot a DAQ Assistant VI és a grafikus 
kijelző köré. 

Futtassuk a VI-t (Run). Folyamatos adatmegjelenítés látható a grafikus 
kijelzőn. Nyomjuk meg a STOP gombot. 

 

A minták száma és a mintavételezési idő módosítható a DAQ Assistant VI-
ra történő kettős kattintással. 

Állítsuk a Samples to Read és a Rate lehetőségeket pl. 100-ra, majd 
kattintsunk az OK gombra. 
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Futtassuk a VI-t (Run), majd a leállításhoz kattintsunk a STOP gombra. 

 

A kijelzés ideje számítható: minták száma x mintavételezési idő 
(1/frekvencia), pl. 100∙1/100 Hz = 1 s. 
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Amikor a VI fut, a feszültség értéke tetszőlegesen változtatható a 
potentiometerrel. A leállításhoz kattintsunk a STOP gombra. 

 

Mentsük el a munkánk „Voltage_Potentiometer” névvel: File → Save. 

Zárjunk be minden megnyitott programot. 
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FOREWORD 

Technological development, economic mass production and the need for the 
expected high quality essentially reformed requirements on the collection, 
storage and registration of measurement data. 

Measurement can be considered to be one of the most inevitable disciplines 
of our age. Several areas of industry demand as part of their daily routines 
the elaboration and implementation of different measurement procedures. 
However, the complexity of measurement tasks made it more and more 
difficult to assess measurement results. Development trends show the 
emergence of automatic measurement systems through all-purpose 
measurement tools and specialised tools and equipment which is a major 
opportunity for solving the above mentioned problem. Measurement uses 
the most up-to-date technology, on the one hand, and it is based on already 
applied and well-established measurement methods and techniques, on the 
other. 

With the appearance and speedy development of computers, measurements 
could have been processed corresponding to the needs of the era, together 
with the possibility to automatize the whole measurement process. The 
collection and storage of measurement data can be done automatically and 
specific software makes it possible to evaluate and print measurements in 
graphic and numeric format. The majority of the users like to see the 
measured values immediately in the moment of the measurement, that is, 
they prefer real-time display. The modern programs include real-time data 
display. 

As a further purpose of the collection and storage of measurement data, we 
may mention the control of the operation of different systems, the 
comparison of planned and implemented systems according to data 
recorded on the long term, the recognition of the potential of the systems, 
the obtaining of data necessary for implementation and of course the 
realisation of required amendments for optimal efficiency. 

To sum up, we can say that although the paper and the pencil are 
important everyday tools of our life, still, they are pushed into the 
background when it comes to the collection, storage and registration of 
measurement data. 
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This book presents modern measurement data acquisition and storage 
opportunities. 

The chapters are broken down as follows: 

Firstly, the SI base and derived units, prefixes and basic principles of 
sensors and data acquisition are summarized in chapter 1. 

Secondly, in chapter 2, a temperature conversion is described in LabVIEW 
environment. 

Next, acquisition and storage of measured data without hardware in 
LabVIEW environment are presented in chapter 3. 

In chapter 4 and chapter 5, data acquisition using NI USB-9211 
thermocouple input device in LabVIEW environment is shown. 

Finally, chapter 6 gives some examples of data acquisition using NI USB-
6009 multifunction I/O device in LabVIEW environment. 
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1. INTRODUCTION TO DATA ACQUISITION 
Measuring is the process of comparing unknown magnitude of certain 
parameter with the known predefined standard of that parameter. 

Measurement is applied in order to determine measured variables. A 
measured value is the value that is determined and indicated at the output 
as the representation of a measured variable. It is indicated as the product 
of a numerical value and the unit of the measured variable (e.g. 30 °C). The 
next main methods of measurement can be distinguished: 
• direct or indirect, and 
• analog or digital. 

Measurement can be considered as an operation of data acquisition and 
presentation. 

This chapter gives a brief overview of SI base and derived units, prefixes, 
basic principles of sensors and data acquisition. 

1.1. SI Base and Derived Units, Prefixes 

The International System of Units (SI) is the standard system of 
measurement. The SI consists of two classes of units: base units and 
derived units. There are seven base units of the SI, as given is Table 1. 

Table 1 Basic SI units 

Quantity Unit 
Name Symbol Name Symbol 

length l meter (metre) m 
mass m kilogram kg 
time t second s 
electric current I ampere A 
thermodynamic temperature T kelvin K 
amount of substance n mole mol 
luminous intensity Iv candela cd 

Derived units are expressed algebraically in terms of base units or other 
derived units. Table 2 lists some examples of derived units. 
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Table 2 Examples of SI derived units 

Quantity Unit 
Name Name Symbol 

area square meter m2 

volume cubic meter m3 

speed, velocity meter per second m·s-1 

acceleration meter per second squared m·s-2 
wave number reciprocal meter m-1 
mass density kilogram per cubic meter kg·m-3 
specific volume cubic meter per kilogram m3·kg-1 

current density ampere per square meter A·m-2 
magnetic field strength ampere per meter A·m-1 

concentration mole per cubic meter mol·m-3 
luminance candela per square meter cd·m-2 

Some SI derived units with special names and symbols are listed in Table 3. 

Table 3 Examples of SI derived units with special names and symbols 

Quantity Unit 

Name Name Symbol Combination of 
Base Units 

plane angle radian rad m·m-1 = 1 
solid angle steradian sr m2·m-2 = 1 
frequency hertz Hz s-1 
force newton N m·kg·s-2 
pressure, stress pascal Pa N/m2, m-1·kg·s-2 
energy, work, quantity of heat joule J N·m, m2·kg·s-2 
power watt W J/s, m2·kg·s-3 
electric charge, quantity of 
electricity 

coulomb C s·A 

electric potential difference, 
electromotive force 

volt V W/A, m2·kg·s-3·A-1 

capacitance farad F C/V, m-2·kg-1·s4·A2 
electric resistance ohm Ω V/A, m2·kg·s-3·A-2 
electric conductance siemens S A/V, m-2·kg-1·s3·A2 
magnetic flux weber Wb V·s, m2·kg·s-2·A-1 
magnetic flux density tesla T Wb/m2, kg·s-2·A-1 
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The SI derived units with special names and symbols given in Table 3 may 
themselves be included in the names and symbols of other SI derived units, 
as shown in Table 4. 

Table 4 Examples of SI derived units whose names and symbols include SI 
derived units with special names and symbols 

Quantity Unit 

Name Name Symbol Combination 
of Base Units 

dynamic viscosity pascal second Pa·s m-1·kg·s-1 
moment of force newton meter N·m m2·kg·s-2 

surface tension 
newton per 
meter 

N/m kg·s-2 

angular velocity 
radian per 
second 

rad/s m·m-1·s-1 = s-1 

angular acceleration 
radian per 
second 
squared 

rad/s2 m·m-1·s-2 = s-2 

heat flux density, irradiance 
watt per 
square meter 

W/m2 kg·s-3 

heat capacity, entropy 
joule per 
kelvin 

J/K m2·kg·s-2·K-1 

specific heat capacity, 
specific entropy 

joule per 
kilogram 
kelvin 

J/(kg·K) m2·s-2·K-1 

specific energy 
joule per 
kilogram 

J/kg m2·s-2 

thermal conductivity 
watt per meter 
kelvin 

W/(m·K) m·kg·s-3·K-1 

energy density 
joule per 
cubic meter 

J/m3 m-1·kg·s-2 

electric field strength volt per meter V/m m·kg·s-3·A-1 

electric charge density 
coulomb per 
cubic meter 

C/m3 m-3·s·A 

surface charge density 
coulomb per 
square meter 

C/m2 m-2·s·A 

permittivity 
farad per 
meter 

F/m m-3·kg-1·s4·A-2 
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The SI prefixes used to form decimal multiples and submultiples of units 
are given in Table 5. 

Table 5 Prefixes 

Factor Name Symbol 
10-24 yocto y 
10-21 zepto z 
10-18 atto a 
10-15 femto f 
10-12 pico p 
10-9 nano n 
10-6 micro µ 
10-3 milli m 
10-2 centi c 
10-1 deci d 
101 deca da 
102 hecto h 
103 kilo k 
106 mega M 
109 giga G 
1012 tera T 
1015 peta P 
1018 exa E 
1021 zetta Z 
1024 yotta Y 

Examples: 
• 3 pF = 3∙10-12 F = 0,000000000003 F, 
• 3 mA = 3∙10-3 A = 0,003 A, 
• 3 GW = 3∙109 W = 3 000 000 000 W, 
• P = U∙I = 3 mV∙3 mA= 3∙10-3 V∙3∙10-3 A = 9∙10-6 V∙A = 9∙10-6 W = 9 µW or 

0,009 mW. 

 
Prefixes must not be used in combination (e.g. 3 µkg): 
• 3 µkg = 3 mg = 0,003 g. 
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1.2. Sensors 

The number of quantities is without limit. The sensor (Figure 1) is a 
converter that measures a physical quantity and converts it into a signal 
(into an electrical signal) which can be read by a device. 

 

Figure 1 Sensor 

Characteristics of sensors can be divided into static and dynamic. Static 
characteristics: relation between the output and input when the input does 
not changes or the input is changing with a slow rate. 

Some static characteristics of sensors: 
• input range, 
• accuracy, 
• resolution, 
• sensitivity, 
• linearity, 
• hysteresis and 
• drift. 

Dynamic characteristics: relationship between the system input and output 
when the measurand is varying rapidly. Three types can be distinguished: 
• Zero order systems (e.g. a potentiometer, see Figure 6), where the input 

and output are related by an equation 

x(t)ya 0 =⋅ . (1) 

• First order systems (e.g. a mercury thermometer immersed into fluid), 
where the input and output related by a first-order differential equation 

x(t)ya
dt
dy

a 01 =⋅+⋅ . 
(2) 
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• Second order systems (e.g. a mass-spring-damper system or a 
thermometer covered for protection), where the input and output are 
related by a second-order differential equation 

x(t)ya
dt
dy

a
dt

yd
a 012

2

2 =⋅+⋅+⋅ . 
(3) 

MATLAB Simulink model of a mass-spring-damper system is presented in 
Figure 2. 

 
Figure 2 MATLAB Simulink model of a mass-spring-damper system 

The second-order step responses are given is Figure 3. 

  

 
Figure 3 Response types: overdamped, critically damped and underdamped 

Overdamped Critically damped 

Underdamped 
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Temperature is one of the most important quantities, and other quantities 
(e.g. resistance, voltage, pressure, volume, length) can depend on it. 

In chapter 3 and chapter 4, a thermocouple type K as sensor is used for 
measuring temperature. A thermocouple consists of two dissimilar metals, 
joined together at one end. When the junction of the two metals is heated or 
cooled a voltage is produced that can be correlated back to the temperature. 

The thermocouple is available in different combinations of metals or calibrations. 
The four most common used types are J, K, T and E. Type K has a Chromel 
(90 % nickel and 10 % chromium) positive leg and an Alumel (95 % nickel, 
2 % manganese, 2 % aluminium and 1 % silicon) negative leg. Some 
structural types of thermocouple are given in Figure 4. 

  

 

Figure 4 Thermocouples for different applications 

Besides thermocouples, RTD and thermistor are also used for temperature 
measurement. RTD (Resistance Temperature Detector) is a temperature 
sensor which measures temperature using the principle that the resistance 
of a metal changes with temperature. Platinum is the most commonly used 
metal for RTD. Thermistor is a semiconductor device whose resistance also 
varies significantly with temperature. Its name comes from a combination of 
the words thermal and resistor. There are two types: NTC (Negative 
Temperature Coefficient) and PTC (Positive Temperature Coefficient). 

Figure 5 lists some widely used types of temperature sensor. 
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Figure 5 Some sensors for measuring temperature 

In subchapter 6.8, a variable resistor (potentiometer) is used as voltage 
divider. A potentiometer is a resistive sensor. There are two types of 
potentiometer: linear and rotary. The linear potentiometer has a slide. The 
rotary potentiometer (Figure 6) can be a single turn or multiturn. 

Quantities 

Electric 

Non electric 

Current Voltage Resistance Etc. 

Level Pressure Temperature Etc. 

Non-contact 

Contact 

RTD 

Thermistor 
 

Thermocouple 
 

Type K 

Type J 

Etc. 

Platinum 

Nickel 

Etc. 

NTC 

PTC 

Etc. 
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Figure 6 Potentiometer as a voltage divider 

1.3. Data Acquisition (DAQ) 

Data acquisition (DAQ) is the process of measuring a quantity such as 
voltage or temperature with an instrument (e.g. digital multimeter or special 
device) supported by software. 

Multimeter combines several measurement functions in one unit and it can 
measure electrical properties, such as voltage, current and resistance. 
Nowadays, most multimeters include the capability to measure, test and 
investigate: 
• frequency, 
• capacity, 
• temperature, 
• diode, 
• transistor and 
• continuity. 

The two main kinds of a multimeter are analog and digital. 

Analog multimeter uses a microammeter whose pointer moves over a 
calibrated scale (Figure 7). The needle is activated by a magnetic field which 
causes it to rotate. Accuracy is the most serious drawback of analog 
multimeter and an analog multimeter can be difficult to read. But, it does 
not require batteries to operate as long as ohms are not being measured 
and it is usually cheaper than digital multimeter. 
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Figure 7 Voltcraft VC-5070 analog multimeter 

Digital multimeter uses digital and logic technology (integrated circuits) and 
DMM enables many new features (e.g. data acquisition, see Figure 8) to be 
embedded in the design. 

  
Figure 8 Data acquisition using digital multimeter 

Principle of digital measurement is illustrated in Figure 9. 
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Figure 9 Principle of digital measurement 

Type METEX M-32 digital multimeter (Figure 10) can be used for data 
acquisition. 

 

Figure 10 METEX M-32 digital multimeter 
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Specifications: 
• AC voltage (400 mV - 750 V), 
• DC voltage (400 mV - 1000 V), 
• AC current (4 mA - 20 A), 
• DC current (4 mA - 20 A), 
• resistance (400 Ω - 40 MΩ), 
• temperature (0 °C - 1000 °C), 
• capacitance (4 nF - 400 nF), 
• diode, transistor, continuity test, 
• 3 3/4 digit (3999 counts), 
• 42 segment analog bar graph display, 
• over-load indication, 
• automatic polarity indication and 
• RS-232C interface. 

The METEX M-32 RS-232 port can be connected to a USB port computer 
using a RS232 to USB adaptor. Scope View software allows to write data 
(e.g. temperature) to text file (Figure 11). 

 

Figure 11 Scope View software 

The acquired data (temperature) with 1 second intervals can be found in 
different lines (Figure 12). 
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Figure 12 Acquired data (temperature) in text file 

Nowadays, instead of digital multimeter special DAQ device is used to 
acquire data. The full DAQ system consists of sensor(s), DAQ device (e.g. NI 
USB-9211, see chapter 4) and computer with software (e.g. LabVIEW) 
(Figure 13). 

  
Figure 13 Data acquisition using DAQ device 
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Next chapters describe modern measurement data collection and storage 
opportunities in LabVIEW environment using National Instruments data 
acquisition devices. 
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2. TEMPERATURE CONVERSION IN 
LABVIEW 
LabVIEW (Laboratory Virtual Instrumentation Engineering Workbench) 
created by National Instruments (NI, www.ni.com) is system design software 
that provides engineers and scientists with the tools needed to create 
measurement and control systems. 

The programming language used in LabVIEW, also referred to as G, is a 
dataflow programming language. This means that LabVIEW uses icons 
instead of lines of text to create applications. LabVIEW programs are called 
Virtual Instruments or VIs for short. 

Every LabVIEW program has two parts: 
• a front panel and 
• a block diagram. 

The front panel serves as a graphical interface for the user, while the block 
diagram contains graphical code elements and connections. 

The next simple model in LabVIEW converts degree Celsius to degree 
Fahrenheit and Kelvin. 

Three temperature scales are widely used today: Celsius, Kelvin and 
Fahrenheit. In the Celsius scale the 0 °C is defined as the freezing point of 
water and 100 °C is defined as the boiling point of water. This scale has 100 
divisions. The Kelvin scale uses the same unit of division as the Celsius 
scale, but it starts at absolute zero. Absolute zero is 0 K = -273.15 ºC. 
Therefore the freezing point of water is 273,15 K and the boiling point of 
water is 373,15 K. The Fahrenheit scale defines the freezing point of water 
as 32 °C and the boiling point of water as 212 °C. This means that between 
the freezing point and boiling point there are 180 divisions. 

The model uses the next equation: 

t[°F] = 1,8∙t[°C]+32,  (4) 

T[K] = t[°C]+273,15.  (5) 

Follow the next easy steps to build your own model for temperature 
conversion. 
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Launch LabVIEW and the Getting Started window appears. This window is 
used to create new VIs, view the most recently opened LabVIEW files, 
launch the LabVIEW help and find examples. 

In the New section of the Getting Started window, click Blank VI to open a 
new VI. 

 

The Front Panel and Block Diagram both appear. You can switch between 
the Front Panel window and Block Diagram window at any time by 
pressing the <Ctrl-E> keys or select Window → Show Front Panel or Show 
Block Diagram. 

 

To see both the Front Panel and Block Diagram at the same time, select 
Window → Tile Up and Down. 



123 

 

Right-click on the Front Panel and select Modern → Numeric → Numeric 
Control. Place the Numeric Control on the Front Panel by moving the 
mouse to the desired location and left-clicking on that spot, then name the 
Numeric Control “Degree Celsius”. 
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Right-click on the Front Panel and select Modern → Numeric → Numeric 
Indicator. Place the Numeric Indicator on the Front Panel and name the 
Numeric Indicator “Degree Fahrenheit”. Select Modern → Numeric → 
Numeric Indicator. Place the Numeric Indicator on the Front Panel and 
name the Numeric Indicator “Kelvin”. 

 

Right-click on the Block Diagram and select Programming → Numeric → 
Multiply to place Multiply function on the Block Diagram. 
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Right-click on the Block Diagram and select Programming → Numeric → 
Add to place the Add function on the Block Diagram. 

 

Right-click on the y input of the Multiply function and select Create → 
Constant to wire a Numeric Constant to the input. Enter 1,8 as numeric 
constant. 
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Right-click on the x input of the Add function and select Create → 
Constant to wire a Numeric Constant to the input. Enter 32 as numeric 
constant. 

 

Right-click on the Block Diagram and select Programming → Numeric → 
Add to place the Add function on the Block Diagram. Right-click on the y 
input of the Add function and select Create → Constant to wire a Numeric 
Constant to the input. Enter 273,15 as numeric constant. 
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Use the Wiring tool ( ) to wire objects together on the block diagram. 
When the mouse hovers over the exit or entry point of a terminal or over a 
wire, the cursor automatically accesses the Wiring tool. 

 

Enter a numeric value (e.g. 100) into the Numeric Control on the Front 
Panel labelled Degree Celsius. Press the Run button to test the program. 

 

The correct values should be displayed in the Numeric Indicators. 
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Save the project under a name like „Temperature_Conversion”: File → 
Save. 

Close LabVIEW. 

Literature 

1. http://www.ni.com/gettingstarted/labviewbasics/tools.htm 
 

http://www.ni.com/gettingstarted/labviewbasics/tools.htm
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3. ACQUISITION AND STORAGE OF 
MEASURED DATA IN LABVIEW WITHOUT 
HARDWARE 
LabVIEW can be used to easily integrate hardware and software to acquire, 
analyse and present data. This chapter describes how you can use 
LabVIEW without hardware for this purpose. Follow the next easy steps to 
build your own model. 

3.1. Simulating a Sine Wave 

Launch LabVIEW and the Getting Started window appears. 

In the New section of the Getting Started window, click Blank VI to open a 
new VI. 

To see both the Front Panel and Block Diagram at the same time, select 
Window → Tile Up and Down. 

Right-click on the Block Diagram and select Express → Input → Simulate 
Signal and place the VI on the Block Diagram. 

In the Configure Simulate Signal dialog box, change the Frequency (Hz) 
to 50 and put a check mark in the box next to Add Noise to add Uniform 
White Noise to the signal, change the Noise amplitude to 0,5, and then 
click OK. 



 130 

  

Right-click on the Sine with Uniform output of the Simulate Signal VI and 
select Create → Graph Indicator. The Graph Indicator appears on the 
Front Panel. 

Run the VI (Run). Data appears on the Front Panel’s Graph Indicator. 
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3.2. Performing Statistical Analysis on the Acquired 
Data 

Right-click on the Block Diagram and select Express → Signal Analysis → 
Statistics to put the Statistics VI on the Block Diagram. 

 

In the Configure Statistics dialog box, select Root mean square (RMS), 
Maximum, Minimum and Range (maximum - minimum). Click OK to 
close the dialog box. 

 

Wire the Signals input of the Statistics VI to the connection between the 
Simulate Signal VI and Graph Indicator with the Wiring tool. 
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Right-click on the RMS, Maximum, Minimum and Range outputs of the 
Statistics VI and select Create → Numeric Indicator, then press the Run 
button. The correct values should be displayed. 

  

3.3. Saving Data to File 

Right-click on the Block Diagram and select Programming → File I/O → 
Write to Measurement File to place this VI on the Block Diagram. 
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In the Configure Write To Measurement File dialog box, select a location 
(if necessary, create one) and file name (e.g. Sine) to store your data, set If a 
file already exists to Overwrite file, then click OK. 

 

Wire the Signals input of the Write to Measurement File VI to the 
connection between the Simulate Signal VI and Graph Indicator with the 
Wiring tool and then run the VI (Run). 
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Save the project under a name like „Sine_SW”: File → Save. 

Close LabVIEW. 

Open the data file (Sine.lvm) to check your work. The number of samples 
should be 100 in Sine.lvm. The number can be modified in the Configure 
Simulate Signal dialog box by double-clicking on the Simulate Signal VI. 

Close Notepad.
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4. TAKING AN NI-DAQMX MEASUREMENT 
WITH NI USB-9211 DEVICE IN LABVIEW 
SIGNALEXPRESS 
LabVIEW SignalExpress is interactive, data-logging software for quickly 
acquiring, analysing and presenting data from hundreds of data acquisition 
devices and instruments. This chapter describes how you can use LabVIEW 
SignalExpress with NI data acquisition device type NI USB-9211. 

4.1. NI USB-9211 Thermocouple Input Module 

The NI USB-9211 data acquisition device provides a USB interface for four 
channels of 24-bit thermocouple inputs with integrated signal conditioning. 
The NI USB-9211 consists of two components: an NI 9211 module and an 
NI USB-9161 carrier (Figure 14). 

  
Figure 14 NI USB-9211 DAQ device 

Specifications: 
• 4 thermocouple inputs, 
• 24-bit resolution, 50/60 Hz noise rejection, 
• 14 S/s sample rate, 
• built-in sensors for cold-junction compensation, 
• compatibility with J, K, R, S, T, N, E, and B thermocouple types and 
• plug-and-play connectivity via USB. 
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Follow the next easy steps to configure and test the device, create a task 
and use it in LabVIEW SignalExpres. The task is a collection of one or more 
virtual channels with timing, triggering and other properties. 

4.2. Configuring and Testing NI USB-9211 

Attach a thermocouple type K to the terminal block (TC0+ and TC0-) and 
plug the USB cable into the PC. When the device is connected to a USB 
port, the LED blinks steadily. 

Select Configure and Test This Device in the New Data Acquisition 
Device window, then click OK or launch Measurement & Automation 
Explorer (MAX) program. 

 

Expand the Devices and Interfaces item, and then expand the NI-DAQmx 
Devices item (if necessary). Check that NI USB-9211 device appears. If the 
device does not appear, press <F5> to refresh the view in MAX. 
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Right-click on the NI USB-9211A: „Dev…” item and select Test Panels… to 
run a test, then click Start. 

 

If the test passed without problems, click Stop, then Close. 
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Right-click on the NI USB-9211A: „Dev…” item and select Device Pinouts 
to get information about pinouts of this device. 

 

Close this window. 

4.3. Creating a Task for Thermocouple 

Right-click on the NI USB-9211A: „Dev…” item and select Create Task…. 

In the Create New NI-DAQmx Task… dialog box, select Acquire Signals → 
Analog Input → Temperature → Thermocouple. 
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Select ai0, and then click Next. 

 

Enter a name for the task: Thermocouple, then click Finish. 
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The Thermocouple task appears under the Data Neighborhood/NI-
DAQmx Tasks item. 

 

Set Thermocouple Type to K and press the Run button. 
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The current temperature should be displayed. Press the Stop button. 

 

Save the configuration (Save). This configuration can be used at any time. 

 

4.4. Using “Thermocouple” Task in LabVIEW 
SignalExpress 

In MAX, expand the Software item and right-click on the LabVIEW 
SignalExpress, and then click Launch LabVIEW SignalExpress. 
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Select Tools → Import NI-DAQmx Task from MAX… to import task 
Thermocouple. In Import NI-DAQmx Task from MAX window, select task 
Thermocouple and click OK. 

 

Set Sample Period (s) to 1, and then change the Step Setup window to 
Data View window. 



143 

 

Drag the Thermocouple item to the Data View window. Click Run to check 
your set. 

 

The current temperature should be shown. Click Stop. 
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Gauge, Large Display, Meter, Slider, Table, Tank, Thermometer, Scalar 
Graph and Scalar XY Graph can be selected instead of chart (right-click on 
the Data View window and select View As). 

To record data, click Record, then select Thermocouple item in the 
Logging Signals Selection window. Change the name to First test, and 
then click OK. 
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To stop recording, click Stop and press OK (if necessary). 
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To monitor recorded data, change the Monitor/Record to Playback by 
clicking on log First test, then drag the First test item to the Data View 
window and run it (Run). 
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To stop running before the end, click Stop. 

 

Save the project under a name like „Thermocouple1_SE”: File → Save 
Project. 

To export data to Microsoft Excel, right-click on the Data View window 
and select Export To → Microsoft Excel. Save the file under a name like 
„Thermocouple1_Excel”. 

Close Microsoft Excel and LabVIEW SignalExpress. 

4.5. Using Two Channels in LabVIEW SignalExpress 

Attach a second thermocouple type K to the terminal block (TC1+ and 
TC1-). Select Thermocouple task, then Add Channels → Thermocouple in 
MAX. 
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Select ai1 in the Add Channels To Task window, and then click OK. 

  

Temperature_0 channel appears in the window. 
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Press the Run button. The current temperature values should be displayed. 
Press the Stop button and save the new configuration (Save). 

Launch LabVIEW SignalExpress. Select Tools → Import NI-DAQmx Task 
from MAX… to import task Thermocouple. In Import NI-DAQmx Task 
from MAX window, select task Thermocouple and click OK. 

Set Sample Period (s) to 1, and then change the Step Setup window to 
Data View window. Click Add Display twice. 
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Expand the Thermocouple item, and then drag the Temperature item to 
the first Data View window, the Temperature_0 item to the second Data 
View window and all Thermocouple item to the third Data View window. 
Click Run button. 

 

Press the Stop button and save the project under a name like 
„Thermocouple2_SE”: File → Save Project. 

Close LabVIEW SignalExpress and MAX. 

Literatures 

1. User Guide and Specifications - NI USB-9211/9211A 
2. http://www.ni.com/labview/signalexpress/ (26/08/2013) 

http://www.ni.com/labview/signalexpress/
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5. ACQUISITION AND STORAGE OF 
MEASURED DATA IN LABVIEW WITH 
HARDWARE (NI USB-9211) 
LabVIEW can be used to easily integrate hardware and software to acquire, 
analyse and present data. This chapter describes how you can use 
LabVIEW with hardware device type NI USB-9211. Follow the next easy 
steps to build your own models. 

5.1. Configuring Hardware-Software Integration 

Attach a thermocouple type K to the terminal block (TC0+ and TC0-) and 
plug the USB cable into the PC. When the device is connected to a USB 
port, the LED blinks steadily. 

Select Configure and Test This Device in the New Data Acquisition 
Device window, then click OK or launch Measurement & Automation 
Explorer (MAX) program. 

Expand the Devices and Interfaces item, and then expand the NI-DAQmx 
Devices item (if necessary). Check that NI USB-9211 device appears. If the 
device does not appear, press <F5> to refresh the view in MAX. 

Launch LabVIEW and the Getting Started window appears. 

In the New section of the Getting Started window, click Blank VI to open a 
new VI. 

To see both the Front Panel and Block Diagram at the same time, select 
Window → Tile Up and Down. 

Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx→ DAQ Assistant and place the VI on the Block Diagram. 

In the Create New Express Task… dialog box, select Acquire Signals → 
Analog Input → Temperature → Thermocouple. 
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Select ai0 for the analog input channel, and then click Finish. 
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Set Thermocouple Type to K, Acquisition Mode to N Samples, Samples 
to Read to 20, Rate (Hz) to 10, and then press the Run button. 

 

The current temperature should be displayed. 

 

Finally, click OK. 
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Right-click on the data output of the DAQ Assistant and select Create → 
Graph Indicator. A Waveform Graph appears on the Front Panel. Run the 
VI (Run). Data appears on the Front Panel’s Graph Indicator. 

 

 

5.2. Performing Statistical Calculation on the Acquired 
Data 

Right-click on the Block Diagram and select Express → Signal Analysis → 
Statistics to put the Statistics VI on the Block Diagram. 
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In the Configure Statistics dialog box, select Root mean square (RMS), 
Maximum, Minimum and Range (maximum - minimum). Click OK to 
close the dialog box. 

 

Wire the Signals input of the Statistics VI to the connection between the 
DAQ Assistant VI and Waveform Graph with the Wiring tool. 

 

Right-click on the RMS, Maximum, Minimum and Range outputs of the 
Statistics VI and select Create → Numeric Indicator, then press the Run 
button. The correct values should be displayed. 
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5.3. Writing Data to File 

Right-click on the Block Diagram and select Programming → File I/O → 
Write to Measurement File to place this VI on the Block Diagram. 

In the Configure Write To Measurement File dialog box, select a location 
(if necessary, create one) and file name (e.g. Thermocouple) to store your 
data, set If a file already exists to Overwrite file, then click OK. 
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Wire the Signals input of the Write to Measurement File VI to the 
connection between the DAQ Assistant VI and Waveform Graph with the 
Wiring tool, and then run the VI (Run). 
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Save the project under a name like „Thermocouple_HW”: File → Save. 

Close this VI. 

Open the data file (Thermocouple.lvm) to check your work. The number of 
samples should be 20 in Thermocouple.lvm. The number can be modified 
by double-clicking on the DAQ Assistant VI. 

Close Notepad. 

5.4. Writing Data to File Continuously 

Open a new VI. 

To see both the Front Panel and Block Diagram at the same time, select 
Window → Tile Up and Down. 

Right-click on the Block Diagram and select Express → Exec Control → 
While Loop to create a while loop on the Block Diagram. Use the cursor to 
draw a rectangle. 
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Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx → Start to put the Start VI on the Block Diagram. 

 

Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx → Stop to put the Stop VI on the Block Diagram. 

 

Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx → Read to put the Read VI on the Block Diagram. 
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Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx → Task Const to put the Task Const VI on the Block Diagram. 

 

Right-click on the Block Diagram and select Programming → File I/O → 
Write to Measurement File to place this VI on the Block Diagram. 

In the Configure Write To Measurement File dialog box, select a location 
(if necessary, create one) and file name (e.g. Thermocouple1) to store your 
data, set If a file already exists to Overwrite file, then click OK. 
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Right-click on the Front Panel and select Express → Graph Indicators → 
Waveform Chart to place this VI on the Front Panel. The Waveform Chart 
appears on the Front Panel. 
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With the Wiring tool wire: 
• the task out output of the Start VI to the task/channels in input of the 

Read VI, 
• the error out output of the Start VI to the error in input of the Read 

VI, 
• the task out output of the Read VI to the task/channels in input of the 

Stop VI, 
• the error out output of the Read VI to the error in input of the Stop VI, 
• the Task Const VI to the task/channels in input of the Start VI, 
• the data output of the Read VI to the Signals input of the Write to 

Measurement File VI and 
• the Waveform Chart to the Signals input of the Write to Measurement 

File VI. 
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Create a new task by switching the Task Const VI and select Browse. The 
Thermocouple task appears. Click Create New… and select MAX Task. 
 

 

In the Create New NI-DAQmx Task… dialog box, select Acquire Signals → 
Analog Input → Temperature → Thermocouple, and then select ai0, and 
then click Next. Enter a name for the task: Thermocouple1, then click 
Finish. 
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Set Thermocouple Type to K and press the Run button. The current 
temperature should be displayed. Click Stop, and then click OK. Select 
Thermocouple1 task in the Select item(s) window and then click OK. 

 

Press the Run button. The correct values should be displayed continuously. 
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Press the STOP button. 

 

The Thermocouple1 task appears under the Data Neighborhood/NI-
DAQmx Tasks item. 

  

Save the project under a name like „Thermocouple_HW1”: File → Save. 

Close LabVIEW and MAX. 

Open the data file (Thermocouple1.lvm) to check your work, and then 
close Notepad. 
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6. DATA ACQUISITION USING NI USB-6009 
MULTIFUNCTION I/O DEVICE 
This chapter describes how you can configure, test and use NI USB-6009 
Multifunction device in LabVIEW environment. 

6.1. NI USB-6009 Multifunction I/O Device 

The NI USB-6009 Multifunction I/O device (Figure 15) provides basic data 
acquisition functionality for applications. 

  

Figure 15 NI USB-6009 DAQ device 

Specifications: 
• 8 analog inputs (14-bit, 48 kS/s), 
• 2 analog outputs (12-bit, 150 S/s), 
• 12 digital I/O, 
• 32-bit counter, 
• digital triggering and 
• bus-powered. 

The components of NI USB-6009 can be seen in Figure 16. 
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Figure 16 Block diagram of NI USB-6009 

GND: Ground - The reference point for the single-ended analog input 
measurements, analog output voltages, digital signals, +5 VDC supply, and 
+2,5 VDC at the I/O connector, and the bias current return point for 
differential mode measurements. 

AI <0...7>: Analog Input Channels 0 to 7 - For single-ended measurements, 
each signal is an analog input voltage channel. For differential 
measurements, AI 0 and AI 4 are the positive and negative inputs of 
differential analog input channel 0. The following signal pairs also form 
differential input channels: AI<1, 5>, AI<2, 6>, and AI<3, 7>. 

AO <0, 1>: Analog Output Channels 0 and 1 - Supplies the voltage output 
of AO channel 0 or AO channel 1. 

P0. <0...7>: Port 0 Digital I/O Channels 0 to 7 - Each signal can be 
individually configured as an input or output. 

P1. <0...3>: Port 1 Digital I/O Channels 0 to 3 - Each signal can be 
individually configured as an input or output. 

PFI 0: PFI 0 - This pin is configurable as either a digital trigger or an event 
counter input. 
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+2,5 V: +2,5 V External Reference - Provides a reference for wrap-back 
testing. 

+5 V: +5 V Power Source - Provides +5 V power up to 200 mA. 

Table 6 and Table 7 list the analog and digital terminal assignments. 

Table 6 Analog terminal assignments 

 

Table 7 Digital terminal assignments 

 



169 

Follow the next easy steps to build your own models. 

6.2. Configuring and Testing NI USB-6009 

Connect „AI0+” channel to the „AO0” channel and „AI0-” channel to the 
„GND” channel (Figure 17), then plug the USB cable into PC. 

 

Figure 17 AI0 and AO0 channels wired together 

Select Configure and Test This Device in the New Data Acquisition 
Device window, then click OK or launch Measurement & Automation 
Explorer (MAX) program. 

Expand the Devices and Interfaces item, and then expand the NI-DAQmx 
Devices item (if necessary). Check that NI USB-6009 device appears. If the 
device does not appear, press <F5> to refresh the view in MAX. 
 

 

Right-click on the NI USB-6009: „Dev…” item and select Test Panels… to 
run a test. 
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Select Analog Output tab and select (e.g.) 2,35 as Output Value, then click 
Update. 

  

Select Analog Input tab, then click Start. 
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If the test passed without problems, click Stop, then Close. 

  

Right-click on the NI USB-6009: „Dev…” item and select Device Pinouts 
to get information about pinouts of this device. 

 

Close this window. 
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6.3. Creating a Task for Voltage 

Right-click on the NI USB-6009: „Dev…” item and select Create Task…. 

In the Create New NI-DAQmx Task… dialog box, select Acquire Signals → 
Analog Input → Voltage. 

 

Select ai0, and then click Next. 

  

Enter a name for the task: Voltage, then click Finish. 
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The Voltage task appears under the Data Neighborhood/NI-DAQmx Tasks 
item. 

 

 

Set Max of Signal Input Range to 5, Min of Signal Input Range to 0, 
Acquisition Mode to 1 Sample (On Demand), and then press the Run 
button. 
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The current voltage (~2,35) should be displayed. Press the Stop button. 

  

Save the configuration (Save). This configuration can be used at any time. 

  

6.4. Using “Voltage” Task in LabVIEW 

Open Thermocouple_HW1 LabVIEW file. Select Voltage task by switching 
the Task Const VI. 
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Double-clicking on the Write to Measurement File VI. In the Configure 
Write To Measurement File dialog box, select a location (if necessary, 
create one) and file name (e.g. Voltage) to store your data, then click OK. 
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Save the project under a name like „Voltage”: File → Save as → Substitute 
copy for original. 

Press the Run button. The correct voltage (~2,35) should be displayed 
continuously. 

  

Press the STOP button. 

  

Open the data file (Voltage.lvm) to check your work, and then close 
Notepad. 

Close this VI. 



177 

6.5. Creating a Task for Input Using DAQ Assistant 

Right-click on the NI USB-6009: „Dev…” item in MAX and select Test 
Panels… to run a test. 

Select Analog Output tab and select (e.g.) 4,5 as Output Value, then click 
Update. 

Select Analog Input tab, then click Start. If the test passed without 
problems, click Stop, then Close. 

Open a new VI. 

To see both the Front Panel and Block Diagram at the same time, select 
Window → Tile Up and Down. 

Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx→ DAQ Assistant and place the VI on the Block Diagram. 

In the Create New NI-DAQmx Task… dialog box, select Acquire Signals → 
Analog Input → Voltage. 

Select ai0, and then click Finish. 

Set Max of Signal Input Range to 5, Min of Signal Input Range to 0, 
Acquisition Mode to 1 Sample (On Demand), and then press the Run 
button. 

The current voltage (~4,5) should be displayed. Press the Stop button. 

Finally, click OK. 

 

Right-click on the data output of the DAQ Assistant and select Create → 
Numeric Indicator. A Numeric Indicator appears on the Front Panel. Run 
the VI (Run). Data (~4,5) appears on the Front Panel’s Graph Indicator. 
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Name the Numeric Indicator “Voltage”. 
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Use while loop for continuous reading from NI USB-6009 device. Right-
click on the Block Diagram and select Express → Exec Control → While 
Loop to create a while loop on the Block Diagram. Use the cursor to drag 
a selection rectangle around the DAQ Assistant VI and Numeric Indicator. 

 

Press the Run button. The correct values (~4,5) should be displayed 
continuously. Press the STOP button. 

 

Save the project under a name like „Voltage_Input”: File → Save. 

Close this VI. 
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6.6. Creating a Task for Output Using DAQ Assistant 

Open a new VI. 

To see both the Front Panel and Block Diagram at the same time, select 
Window → Tile Up and Down. 

Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx→ DAQ Assistant and place the VI on the Block Diagram. 

In the Create New NI-DAQmx Task… dialog box, select Generate Signals 
→ Analog Output → Voltage. 

 

Select ao0, and then click Finish. 
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Click OK. 

 

Right-click on the Front Panel and select Express → Num Ctrls → Num 
Ctrl. A Numeric Control appears on the Front Panel. Name the Numeric 
Control “Voltage Output”. 

  

Wire the data input of the DAQ Assistant VI to the output of the Numeric 
Control with the Wiring tool. 
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Enter 3 and run the VI (Run). 

 

Run Voltage_Input.vi (Run). The correct value (~3) should be displayed. 
Press the STOP button. 

  

  

Use while loop for continuous writing to NI USB-6009 device. Right-click 
on the Block Diagram and select Express → Exec Control → While Loop 
to create a while loop on the Block Diagram. Use the cursor to drag a 
selection rectangle around the DAQ Assistant VI and Numeric Control. 
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Run the programs (Run). The correct value (~3) should be displayed and 
can be modified continuously. Finally, press the STOP buttons. 

Save the project under a name like „Voltage_Output”: File → Save. 

Close this VI. 

6.7. Advanced File I/O Operation 

Use the Voltage_Output.vi. 

Enlarge the rectangle of the while loop. 
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Copy Start VI, Stop VI, Read VI, Task Const VI and Waveform Chart 
from Voltage.vi. (SHIFT+left-click on the items, then Edit → Copy (or 
CTRL+C) and Edit → Paste (or CTRL+V).) 
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Right-click on the Block Diagram and select Programming → File I/O → 
Format into File. 

 

Enlarge the Format into File item to see four inputs (input 1, input 2, 
input 3 and input 4). Right-click on the Block Diagram and select 
Programming → File I/O → Open/Create/Replace File. 
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Right-click on the file path (use dialog) input of the Open/Create/Replace 
File item and select Create → Control. 

Right-click on the operation (0: open) input of the Open/Create/Replace 
File item and select Create → Constant and then replace or create. 

 

A file path appears on the Front Panel. 
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Right-click on the Block Diagram and select Programming → File I/O → 
Close File. 

 

Right-click on the Block Diagram and select Programming → Timing → 
Wait Until Next ms Multiple. 
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Right-click on the millisecond multiple input of the Wait Until Next ms 
Multiple item and select Create → Control and place it outside the while 
loop. 

 

A millisecond multiple control appears on the Front Panel. 

 

Place a Multiply item on the Block Diagram: right-click on the Block 
Diagram and select Programming → Numeric → Multiply. 
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To see the data separately and in new lines later, right-click on the Block 
Diagram and select Programming → String → Tab Constant, then 
Programming → String → End of Line Constant. 
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With the Wiring tool wire: 
• the task out output of the Start VI to the task/channels in input of the 

Read VI, 
• the error out output of the Start VI to the error in input of the Read 

VI, 
• the task out output of the Read VI to the task/channels in input of the 

Stop VI, 
• the error out output of the Read VI to the error in input of the Stop VI, 
• the Task Const VI to task/channels in input of the Start VI, 
• the millisecond multiple control to the While Until Next ms Multiple, 
• the refnum out output of the Open/Create/Replace File to the input 

file input of the Format into File, 
• the error out output of the Open/Create/Replace File to the error in 

input of the Format into File, 
• the output file refnum output of the Format into File to the refnum 

input of the Close File, 
• the error out output of the Format into File to the error in input of the 

Close File, 
• the x input of the Multiply to the connection between millisecond 

multiple control and While Until Next ms Multiple, 
• the Loop iteration to the y input of Multiply, 
• the x*y output of the Multiply to the input 1 input of the Format into 

File, 
• the Tab Constant to the input 2 input of the Format into File, 
• the data output of the Read VI to the input 3 input of the Format into 

File, 
• the Waveform Chart to the connection between Read VI and input 3 

input of the Format into File and 
• the End of Line Constant to the input 4 input of the Format into File. 
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Save the project under a name like „Voltage_Input_Output”: File → Save 
as → Substitute copy for original. 

Select a location (if necessary, create one) and file (e.g. 
Voltage_Input_Output.txt) to store your data. Set (e.g.) 3 as Voltage 
Output and (e.g.) 100 as millisecond multiple. Run the VI (Run). 

 

The correct value (~3) should be shown in the Waveform Chart. Click 
STOP. 
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Open the data file (Voltage_Input_Output.txt) to check your work. The 
acquired data with 100 ms intervals can be found in different lines. 

 

Close Notepad. 

To see the time in seconds, a Divide item is needed: right-click on the 
Block Diagram and select Programming → Numeric → Divide. 

Delete the connection from the x input of the Multiply. Right-click on the y 
input of the Divide function and select Create → Constant to wire a 
Numeric Constant to the input. Enter 1000 as numeric constant. 

With the Wiring tool wire the x input of the Divide to the connection 
between the millisecond multiple Control and While Until Next ms 
Multiple, and then x/y output of the Divide to the x input of the Multiply. 
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Run the VI (Run), and then click STOP. Open the data file 
(Voltage_Input_Output.txt). The acquired data in second with 100 
millisecond intervals can be found. 

 

Name the items. 
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To clean the Block Diagram, use Clean Up Diagram button. 

 

Save the project: File → Save. 

Close the VIs and Notepad. 

6.8. Creating a Task for Voltage Input Using Variable 
Resistance 

Attach a potentiometer to the terminal block as shown is Figure 18 and 
plug the USB cable into the PC. When the device is connected to a USB 
port, the LED blinks steadily. 
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Figure 18 Connecting potentiometer to the DAQ device 

Open a new VI. To see both the Front Panel and Block Diagram at the 
same time, select Window → Tile Up and Down. 

Right-click on the Block Diagram and select Measurement I/O → NI-
DAQmx→ DAQ Assistant and place the VI on the Block Diagram. 

In the Create New Express Task… dialog box, select Acquire Signals → 
Analog Input → Voltage. 

Select ai0, and then click Next. 

Set Max of Signal Input Range to 5, Min of Signal Input Range to 0, 
Terminal Configuration to RSE, and then press the Run button. The value 
of voltage has to be lower than 5. 

+5V AI0+  GND 
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This value can be changed by potentiometer. 
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Finally, click OK. 

Right-click on the Front Panel and select Express → Graph Indicators → 
Waveform Graph to place this VI on the Front Panel. The Waveform 
Graph appears on the Front Panel. 

Wire the data output of the DAQ Assistant VI to the Waveform Graph with 
the Wiring tool. 

Press the Run button to test the program. 
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Use while loop for continuous reading. Right-click on the Block Diagram 
and select Express → Exec Control → While Loop to create a while loop 
on the Block Diagram. Use the cursor to drag a selection rectangle around 
the DAQ Assistant VI and Waveform Graph. 

Run the VI (Run). Continuous data flow can be seen in Waveform Graph. 
Click STOP. 

 

The number of samples and sampling interval can be modified by double-
clicking on the DAQ Assistant VI. 

Set Samples to Read to 100 and Rate to 100, then click OK. 
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Run the VI (Run), and then click STOP. 

 

The time can be calculated: samples x sampling interval (1/rate), e.g. 
100∙1/100 Hz = 1 s. 
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When the VI runs, the value of voltage can be changed by potentiometer. 
Press the STOP button. 

 

Save the project under a name like „Voltage_Potentiometer”: File → Save. 

Close all programs. 
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